This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 64563 - configuring multiple servers w/ fetchmailconf breaks .fetchmailrc
configuring multiple servers w/ fetchmailconf breaks .fetchmailrc
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: fetchmail (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-07 19:54 EDT by Ben Levenson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 12:48:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2002-05-07 19:54:10 EDT
Description of Problem:
adding a second server to .fetchmailrc with fetchmailconf horks the config
file. The problem seems to be with the "port None" syntax. Here is a copy 
of the problematic .fetchmailrc:
  # Configuration created Tue May  7 19:41:47 2002 by fetchmailconf
  set postmaster "postmaster"
  set bouncemail
  set no spambounce
  set properties ""
  poll server1.somewhere.com with proto IMAP port None
         user 'foobar' there with password 'hackme' is 'root' here options keep ssl

  poll server2.somewhereelse.com with proto IMAP
         user 'foobar' there with password 'hackme' is 'root' here options keep ssl

Version-Release number of selected component (if applicable):
fetchmailconf-5.9.0-5
fetchmail-5.9.0-5

How Reproducible:
100%

Steps to Reproduce:
1. use fetchmailconf to add server1
2. test config to verify that it is correct
3. save and quit fetchmailconf
4. examine ~/.fetchmailrc. notice that there is no "port None" statement
   after the entry for server1
5. use fetchmailconf add server2
6. save and quit
7. cat ~/.fetchmailrc and notice "port None" option after server1 entry 
8. run 'fetchmail --configdump' and note syntax error: "parse error at None"

Expected Results:
no parse error -- working .fetchmailrc.

Additional Information:
deleting "port None" fixes it.
Comment 1 Ben Levenson 2004-06-21 12:48:14 EDT
no fetchmailconf in RHEL3 

Note You need to log in before you can comment on or make changes to this bug.