Bug 645727 - get different pci address from pci_addr value when hot add device
get different pci address from pci_addr value when hot add device
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Alex Williamson
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2010-10-22 06:07 EDT by Shirley Zhou
Modified: 2015-03-04 19:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-20 15:29:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shirley Zhou 2010-10-22 06:07:05 EDT
Description of problem:
when hot add device, we can set pci address via option "pci_addr=", while we get different pci address from pci_addr value.

And when set a pci address already used by other device, no error prompts.

Version-Release number of selected component (if applicable):
kvm-83-205.el5

How reproducible:
100%

Steps to Reproduce:
1.start guest
[root@amd-2427-32-1 images]# /usr/libexec/qemu-kvm -M rhel5.6.0 -m 2048 -smp 2 -name test-qcow2 -uuid 39a565d2-2032-848d-bda0-de7adb149048 -monitor stdio -boot c -drive file=/var/lib/libvirt/images/test.qcow2,if=ide,bus=0,unit=0,boot=on,format=qcow2,werror=stop -net nic,macaddr=54:52:00:27:cd:13,vlan=0,model=virtio -net tap,vlan=0  -usb -usbdevice tablet -vnc :1 -k en-us -vga cirrus 
2. check pci device via monitor
(qemu) info pci
  Bus  0, device   0, function 0:
    Host bridge: PCI device 8086:1237
  Bus  0, device   1, function 0:
    ISA bridge: PCI device 8086:7000
  Bus  0, device   1, function 1:
    IDE controller: PCI device 8086:7010
      BAR4: I/O at 0xc000 [0xc00f].
  Bus  0, device   1, function 2:
    USB controller: PCI device 8086:7020
      IRQ 11.
      BAR4: I/O at 0xc020 [0xc03f].
  Bus  0, device   1, function 3:
    Bridge: PCI device 8086:7113
      IRQ 9.
  Bus  0, device   2, function 0:
    VGA controller: PCI device 1013:00b8
      BAR0: 32 bit memory at 0xc2000000 [0xc3ffffff].
      BAR1: 32 bit memory at 0xc4000000 [0xc4000fff].
  Bus  0, device   3, function 0:
    Ethernet controller: PCI device 1af4:1000
      IRQ 11.
      BAR0: I/O at 0xc040 [0xc05f].
  Bus  0, device   4, function 0:
    RAM controller: PCI device 1af4:1002
      IRQ 11.
      BAR0: I/O at 0xc060 [0xc07f]
3.hot add pci device via monitor
(qemu) pci_add  pci_addr=3  nic model=rtl8139
note: pci_addr has already used by other device.
4.hot add another device via monitor
(qemu) pci_add  pci_addr=9  nic model=rtl8139

Actual results:
after step3, no error prompts pci_addr=3 is in used, while we get info:
(qemu) pci_add  pci_addr=3  nic model=rtl8139
OK domain 0, bus 0, slot 5, function 0

after step4, we get info as following, pci_addr should be 9 not 6
(qemu) pci_add  pci_addr=9  nic model=rtl8139
OK domain 0, bus 0, slot 6, function 0

Expected results:
after step3, should be error prompts pci_addr=3 is in used.
after step4, rtl8139 should inserted with pci_addr=9

Additional info:
Comment 2 RHEL Product and Program Management 2011-01-11 15:53:13 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-11 17:54:53 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 7 Bill Burns 2011-01-20 15:29:52 EST
Closed as this is low impact and unlikely to be fixed for RHEL 5.

Note You need to log in before you can comment on or make changes to this bug.