Bug 64574 - Default route for xDSL connections not set
Default route for xDSL connections not set
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp-pppoe (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 01:54 EDT by tswan
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 16:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tswan 2002-05-08 01:54:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Steps to reprodcue

After activating the connection the default route still is assigned to the eth0
gateway and not to the ppp0 interface gateway.  Check with "ip route"  this
behavior was not seen in RH 7.2 but was seen in Skipjack Beta 1 and 2.  
Subsequent upgrades through rawhide RPMs never saw this corrected. 

Currently, I have to ip route delete default; ip route add default via x.x.x.x
dev ppp0 to get any outside network connections.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a xDSL connection using the redhat-config-network-druid program.  
2. Let this use eth0 to get to the DSL modem.  
3. Check the option to have this assigned as the default route.
4. Activate the ppp0 interface either by using the druid or by using if up ppp0
5. Check with "ip route" the default route is never set to the ppp0 interface
	

Actual Results:  Default route not assiged

Expected Results:  Default route should be assigned to the gateway of the ppp0
interface

Additional info:

This worked prior to SkipJack Beta 1 and Beta 2.   I never checked pass those
beta stages and hoped it would have been fixed.  This never occurred with RH
7.2.    The ppp0 interface is using PPPoE via eth0 through a DSL Modem (Alcatel
@Home)

This is a *severe* usability bug for DSL users and a connectivity regression
over RedHat 7.2
Comment 1 Steffen Mann 2002-05-09 05:50:19 EDT
I see similar behaviour, setting the gateway to my server. Via neat fine. Reboot
- gateway gone. I either manually need to do a add default gw x.x.x.x and it's
there or start neat and set gw again - doing so strangely enough in the first
place there is no gw at all then by setting it the previously set gw's are
there..... by adding more and more gw, the list then is gettting longer.
Comment 2 Need Real Name 2002-05-18 09:26:49 EDT
I have fount the same problem too in my RH7.3 whit adsl connection. 
Is true, the mistake is in the route set makes from pppoe and after the update 
of the rp-pppoe package i have correct it.
there isn't an rpm but i have found only the sources with a simply gui for the 
setup...
regards
Comment 3 Ngo Than 2002-06-19 04:35:39 EDT
Could you please attach your adsl config file (ifcfg-ppp0)?
Which version of rp-pppoe and redhat-config-network did you install?

It works fine for me with T-DSL. Harald, do you have this problem with your T-DSL?
Comment 4 Harald Hoyer 2002-06-26 10:30:58 EDT
seems to be a problem of rp-pppoe
Comment 5 Ngo Than 2002-06-26 16:40:45 EDT
if you try to setup DSL connection, make sure that "Make this connection the
default route" is enable. It should work fine.

Note You need to log in before you can comment on or make changes to this bug.