Bug 645756 - Impossible to boot relocatable kernel.
Impossible to boot relocatable kernel.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yaboot (Show other bugs)
5.6
ppc64 Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jiri Skala
Martin Banas
: ZStream
Depends On:
Blocks: 647777 sat541-triage
  Show dependency treegraph
 
Reported: 2010-10-22 08:01 EDT by Jiri Kastner
Modified: 2014-11-09 17:33 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 03:06:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch allowing to boot relocatable kernels (1.05 KB, patch)
2010-10-26 07:22 EDT, Roman Rakus
no flags Details | Diff

  None (edit)
Description Jiri Kastner 2010-10-22 08:01:15 EDT
Description of problem:
rhel6 -> rhel5 provisioning not working, because old yaboot doesn't recognize rhel6 kernel image as valid elf image.

Version-Release number of selected component (if applicable):


How reproducible:
always on rhel5 ppc

Steps to Reproduce:
1. prepare rhel5 ppc machine and satellite-5.4 for provisioning ppc rhel6
2. update it
3. register rhel5 ppc to satellite
4. create kickstart
5. launch this kickstart
6. connect to ppc client console
7. rhel6 kickstart fails
8. boot to linux (boot: linux)
9. download rhel6 yaboot package and extract it and replace files from old yaboot
10. run 'ybin' and reboot again and let machine boot kickstart
11. kernel image is loaded and kickstart launched
  
Actual results:
Welcome
Welcome to yaboot version 1.3.13 (Red Hat 1.3.13-10.el5)
Enter "help" to get some basic usage information
boot: kick1287747852
Please wait, loading kernel...
/vmlinuz: Not a valid ELF image

Expected results:
boot: kick1287747852 
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 03600000, size: 30590 Kbytes
.....

Additional info:
Comment 1 Martin Banas 2010-10-22 08:07:37 EDT
Roman,

Could you please tell us if booting RHEL6 kernel from RHEL5 yaboot should be supported?

Thanks.
Comment 2 Roman Rakus 2010-10-25 11:34:44 EDT
Can you please try http://rrakus.fedorapeople.org/yaboot-1.3.13-11.el5.ppc.rpm ?
Comment 4 Roman Rakus 2010-10-26 07:11:44 EDT
Ok. Let me do some magic with this bug.
Comment 5 Roman Rakus 2010-10-26 07:22:05 EDT
Created attachment 455739 [details]
Patch allowing to boot relocatable kernels
Comment 7 RHEL Product and Program Management 2010-10-26 08:07:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 Roman Rakus 2010-10-29 08:20:25 EDT
Patch commited.
Comment 15 errata-xmlrpc 2011-07-21 03:06:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0993.html

Note You need to log in before you can comment on or make changes to this bug.