Bug 64580 - Install from harddisk fails with python stacktrace
Install from harddisk fails with python stacktrace
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 05:16 EDT by Nils Olav Selåsdal
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-06 09:34:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Olav Selåsdal 2002-05-08 05:16:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
I tried to install RH7.3 from harddisk, ISO files resides on a fat32 disk.
What happens is that after i choose the directory where the isofiles are, it:
1. Tells me Graphical install isnt available for harddisk installs.
2. probes for my video card, correctly identifies it as a 3d ati rage card.
3. probes for my monitor (A Nokia 449M), fails with "unable to probe".
4. probes for my mouse, correctly identifying it (its a standard 3d buton ps/2 
mouse.
4. booom.. fails with a python stacktrace. From what I recall it says
that None doesnt subbort the height property.
5. Bails out, tells me to reboot


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from bootdisk 
2. Choose install from harddisk
		

Actual Results:  Install fails as described above

Additional info:

RH 7.2/7.1 installs perfectly on the same machine.
I have not yet tried installing TH 7.3 from CDROM.
Comment 1 Michael Fulbright 2002-05-09 14:38:06 EDT
Were you given the option to safe the traceback to floppy? We really need it to
diagnose this issue further.
Comment 2 Nils O. Selåsdal 2002-05-19 07:26:15 EDT
Ok, here is the traceback, I probably mixed up some upper/lowercase and 
spaces: 
Probing for videocard: ATI Mach64 3D Rage IIc 
Probing for monitor type: Unable to probe 
Probing for mouse type: Generic - 3 Button Mouse(PS/2) 
Graphical installation not available for hd installs. Starting textmode 
Traceback(Innermost last) 
File "/usr/bin/anaconda", line 657 in 2. 
method = HardDriveInstallMethod(drive,type,dir,intt,messageWindow) 
File "/usr/src/build/90289-i386/install/usr/lib/anaconda/harddrive.py", line 
211 in __init__ 
File "/usr/src/build/90289-i386/install/usr/lib/anaconda/image.py", line 206 
in findISOImages 
File "/usr/src/build/90289-i386/install/usr/lib/anaconda/text.py", line 264 in 
messageWindow 
File "/usr/src/build/90289-i386/install/usr/lib/anaconda/taxt.py", line 117 in 
__init__ 
File "/usr/lib/python/site-packages/snack.py", line 547 in ButtonChoiceWindow 
t = TextBoxReflowed(width,text,maxHeight = screen.height-12) 
AttributeError: 'None' has no attribute 'height' 
Install exited abnormally 
 
Luckily(for me), graphical install from CDROM worked. 
Comment 3 Nils O. Selåsdal 2002-05-19 07:33:41 EDT
>Were you given the option to safe the traceback to floppy? 
Missed thisone. No, I were not given that option, I wrote the traceback I 
posted 
of the screen. 
Comment 4 Michael Fulbright 2002-06-12 12:43:30 EDT
Could you please mediacheck the ISO images - instructions are at:

http://people.redhat.com/~msf/mediacheck.html

(it works for HD ISO installs as well as CD installs)
Comment 5 Need Real Name 2002-07-06 09:34:26 EDT
Hi there,

I have exactly the same problem, same messages appearing. However, when I 
type 'linux mediacheck' it doesn't appear to make a difference, it doesn't ask 
me any questions apart from what language I want, what keyboard layout and 
where the .iso files are. What am I doing wrong?

Regards
Comment 6 Michael Fulbright 2002-07-15 12:57:52 EDT
Good to hear the graphical install worked.  Sounds like a bad ISO set to get the
error you were seeing.

Note You need to log in before you can comment on or make changes to this bug.