Bug 645829 - Curly brackets used in macro delimiters are trimmed when creating a configuration file via WebUI
Curly brackets used in macro delimiters are trimmed when creating a configura...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management (Show other bugs)
540
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Pavel Novotny
: Regression
: 654121 (view as bug list)
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-10-22 11:15 EDT by Pavel Novotny
Modified: 2010-12-16 11:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, using WebUI to create a new configuration caused all curly brackets (that is, "{" and "}") to be removed. This error has been fixed, and curly brackets are now correctly accepted in macro delimiters.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 10:45:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Novotny 2010-10-22 11:15:33 EDT
Description of problem:
Creating a new configuration file via WebUI causes that curly brackets used in macro delimiters are trimmed. 

Version-Release number of selected component (if applicable):
spacewalk-java-1.2.39-29.el5sat
spacewalk-config-1.2.2-1.el5sat

How reproducible:
Always

Steps to Reproduce:
1. Create a configuration channel (Configuration -> Configuration Channels -> create new config channel)
2. Create configuration file (conf. channel -> Add files -> Create file) 
and set macro delimiters to '{|', '|}' or '{@', '@}'.
3. Submit the form.
  
Actual results:
Curly brackets are trimmed in macro delimiter fields. You can see only '|', '|' or '@', '@'.

Expected results:
Do not trim curly brackets!

Additional info:
Config file created with client tools (rhncfg-manager add --delim-start=...) is *not* affected by this behaviour and delimiters are saved correctly. So this issue is surely only matter of WebUI or some backend package.
Comment 1 Tomas Lestach 2010-11-02 13:44:51 EDT
Do not "scrub" cffMacroStart and cffMacroEnd
spacewalk.git: 8b32a8722ea2f85c1456c84ec02aef19dc0e20ab

I found out, there's one more issue - it was impossible to update macro delimiters on the rhn/configuration/file/FileDetails.do page.
Available fix:
spacewalk.git: 72e8dccd46d1336c633f298fc7bba28340735e9a
Comment 2 Clifford Perry 2010-11-17 17:21:25 EST
bug 654121 - maybe same issue? Srubbing of the Marco's incorrectly.
Comment 3 Xixi 2010-11-17 17:33:55 EST
*** Bug 654121 has been marked as a duplicate of this bug. ***
Comment 11 Pavel Novotny 2010-12-07 10:58:19 EST
Failed QA.

Curly brackets are still trimmed in the same way as described in comment #0.

# rpm -q spacewalk-java
spacewalk-java-1.2.39-33.el5sat
Comment 15 Pavel Novotny 2010-12-13 11:42:53 EST
Verified. 

I used characters such as '{|', '{@', '{}|', '{{@' as macro delimiters and all were saved successfully without trimming.

# rpm -q spacewalk-java
spacewalk-java-1.2.39-34.el5sat
Comment 17 errata-xmlrpc 2010-12-16 10:45:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0991.html
Comment 18 Jaromir Hradilek 2010-12-16 11:33:49 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, using WebUI to create a new configuration caused all curly brackets (that is, "{" and "}") to be removed. This error has been fixed, and curly brackets are now correctly accepted in macro delimiters.

Note You need to log in before you can comment on or make changes to this bug.