This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 645869 - configure --disable-appliance should not need to check for febootstrap + debootstrap
configure --disable-appliance should not need to check for febootstrap + debo...
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-22 13:40 EDT by Richard W.M. Jones
Modified: 2010-10-26 07:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-26 07:34:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-10-22 13:40:41 EDT
Originally reported by Andreis_Vinogradovs (slepnoga) here:
https://bugs.gentoo.org/show_bug.cgi?id=302614#c7

Description of problem:

If we are configured with --disable-appliance, then there
is no point checking for febootstrap and debootstrap, since
they cannot be needed.

Version-Release number of selected component (if applicable):

libguestfs 1.5.21

How reproducible:

Always.

Steps to Reproduce:
1. Remove febootstrap, debootstrap or use a platform which
   doesn't have either.
2. ./configure --disable-appliance --disable-daemon
3.

Actual results:

configure prints
Either febootstrap or debootstrap must be installed

Expected results:

Should not print that because these are only required to
build the appliance.

Additional info:
Comment 1 Richard W.M. Jones 2010-10-26 07:34:51 EDT
This is NOTABUG.  It's already fixed in the latest libguestfs
by commit ef044690c54deb597bfe706cb88849dda5ebe8fc (since March 2010)
so whatever ancient version of libguestfs you were trying, you need
to upgrade to a much newer version.

Note You need to log in before you can comment on or make changes to this bug.