This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 64589 - poor installation, most i18n missing (fix provided)
poor installation, most i18n missing (fix provided)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 08:29 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-01 09:38:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-08 08:29:07 EDT
Try this

LANG=it_IT xterm -e vim (Should give you Italian messages)

or

LANG=ja_JP gvim (Japanese messages *and* menus)

or this

LANG=pl_PL.utf8 LC_CTYPE=pl_PL.UTF-8 xterm -fn
"-Misc-Fixed-Medium-R-Normal--18-120-100-100-C-90-ISO10646-1" -e vim "+set
keymap=greek_utf-8"

(Polish messages, with greek keymapping so Polish people can type greek
 characters in an UTF-8 file)

etc.

None of these work. In none of the rh versions: 7.3, 7.2, 7.1 ..
I found out when I needed to change the keymap to enter text in another language.
In fact it turned out that redhat simply `forgot' to install all kind of files.
Maybe because some lines in the spec file got so convoluted that nobody
dared touch it ?

What really amazes me is that this apparently went undetected for so long ..

1) none of rh users uses the best editor in the world ?
2) none of rh users uses anything but LANG=en_US ?
3) none of rh users bothers to file a bug report ?
4) nobody at rh watches the competition (PLD, mandrake have working versions) ?
4) ??

Anyway the only point I can influence myself is 3).
I've put up a src.rpm on
http://lanceerplaats.nl/downloads/SRPMS/vim-6.1-3.src.rpm
I'll only leave it there untill after a few downloads.
OBdisclaimer: It works for me, I do not work for redhat.

Note you need to *at least* change  --with-compiledby ..
You can easily see by comparing the spec files that
it really is not that different ..


Regards,
Harold.
Comment 1 Bernhard Rosenkraenzer 2002-07-01 09:38:06 EDT
Actually none of your possible reasons are the case - (2) comes close though, 
I  
use LANG=C. ;)  
  
Fixed in 6.1-7

Note You need to log in before you can comment on or make changes to this bug.