Bug 645937 - kernel-2.6.35 no longer creates /proc/acpi/event, which breaks sony_laptop
kernel-2.6.35 no longer creates /proc/acpi/event, which breaks sony_laptop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-22 23:04 EDT by Rohan Dhruva
Modified: 2013-01-10 03:13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-14 03:48:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evtest output (2.07 KB, text/plain)
2010-11-03 11:24 EDT, Rohan Dhruva
no flags Details

  None (edit)
Description Rohan Dhruva 2010-10-22 23:04:57 EDT
Description of problem:
Kernel 2.6.35 in F14 has disabled CONFIG_ACPI_PROC_EVENT. I have a Sony Vaio CW laptop, which relies on the sony_laptop kernel module to catch acpi hotkey events. Thus, in Fedora 14, pressing Fn+F5 (brightness down) is not recognized at all, and pressing Fn+F6 is recognized as a generic button, having no effect on brightness. I use the nvidia_bl driver, and oBacklight to control the brightness.

Version-Release number of selected component (if applicable):
kernel-2.6.35.6-45.fc14.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start acpi_listen
2. Press the brightness up key (Fn+F5)
3. Press the brightness down key (Fn+F6)
  
Actual results:
Brightness down registers no event.
Brightness up gives "button/fnf6 FNF6 00000080 00000000"

Expected results:
Fn+F5 should give- sony/hotkey SNC 00000001 00000010
Fn+F6 should give- sony/hotkey SNC 00000001 00000011

Additional info:
I realize that CONFIG_ACPI_PROC_EVENT is deprecated, but this causes a major loss of functionality for all Sony laptops relying on it. I am quite sure this problem affects other Sony laptops too, not only Vaio CW. I request that CONFIG_ACPI_PROC_EVENT is enabled, at least until an alternative is found.
Comment 1 Matthew Garrett 2010-11-03 10:47:31 EDT
Brightness events should be generating KEY_BRIGHTNESSUP and KEY_BRIGHTNESSDOWN - is that not happening?
Comment 2 Rohan Dhruva 2010-11-03 10:50:45 EDT
No, they are not generating those events (can't see in xev). On enabling CONFIG_ACPI_PROC_EVENT (by recompiling the kernel), at least acpi_listen generates correct output. But xev never shows KEY_BRIGHTNESSUP or KEY_BRIGHTNESSDOWN, in either case.
Comment 3 Matthew Garrett 2010-11-03 11:10:04 EDT
You won't see them in xev if you have a power manager that's taken a grab. Can you install evtest and run it against the Sony Vaio keys device and see whether they appear there?
Comment 4 Rohan Dhruva 2010-11-03 11:24:17 EDT
evtest does show that key events are caught. I had a talk with the maintainer of this module (Mattia Dongili). He told that the problem may be occurring because X protocol can't handle keys with scancodes > 255 (http://bugs.freedesktop.org/show_bug.cgi?id=11227).

Is there any way I can key scancode 470 and 471 to KEY_BRIGHTNESSDOWN and KEY_BRIGHTNESSUP respectively? I am attaching the output of evtest (event8 is the Sony Vaio Keys event handler).
Comment 5 Rohan Dhruva 2010-11-03 11:24:47 EDT
Created attachment 457467 [details]
evtest output
Comment 6 Matthew Garrett 2010-11-03 11:33:18 EDT
Ah, in that case we just need to fix up the keymap. I'll look into that, thanks!
Comment 7 Rohan Dhruva 2010-11-12 16:28:01 EST
Hello.. Any updates on this? Will this be fixed for Fedora 14? Thanks.
Comment 8 Rohan Dhruva 2011-01-10 00:45:30 EST
Bump
Comment 9 Rohan Dhruva 2011-03-14 03:48:48 EDT
I can confirm that brightness control keys work for me on the Fedora 15 alpha release.

Note You need to log in before you can comment on or make changes to this bug.