Bug 646053 - F14 Install failed. Error processing drive
F14 Install failed. Error processing drive
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
16
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-24 01:25 EDT by Zach Carter
Modified: 2011-12-03 21:46 EST (History)
6 users (show)

See Also:
Fixed In Version: parted-2.3-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-03 21:41:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of error message (1.44 MB, image/jpeg)
2010-10-24 01:25 EDT, Zach Carter
no flags Details
output of vgdisplay -v (13.79 KB, text/plain)
2010-10-24 01:26 EDT, Zach Carter
no flags Details
Output of fdisk -l (10.87 KB, text/plain)
2010-10-24 01:27 EDT, Zach Carter
no flags Details
storage.log (309.03 KB, text/plain)
2010-10-24 01:50 EDT, Zach Carter
no flags Details
program.log (58.99 KB, text/plain)
2010-10-24 01:50 EDT, Zach Carter
no flags Details
anaconda.log (6.43 KB, text/plain)
2010-10-24 01:51 EDT, Zach Carter
no flags Details
The output of "parted -l" (11.14 KB, text/plain)
2010-10-25 21:08 EDT, Zach Carter
no flags Details
The output of "parted /dev/sdd print" (181 bytes, text/plain)
2010-10-26 22:03 EDT, Zach Carter
no flags Details
contents of mbr (512 bytes, application/octet-stream)
2010-11-13 01:04 EST, Zach Carter
no flags Details
MBR plus additional sector (1.00 KB, application/octet-stream)
2010-11-18 23:07 EST, Zach Carter
no flags Details

  None (edit)
Description Zach Carter 2010-10-24 01:25:15 EDT
Created attachment 455305 [details]
Picture of error message

Description of problem:

Booting from the Fedora 14 install DVD, the installer is unable to read my LVM setup, complaining about one of the disk drives.  However, I don't see anything wrong with them.  The only way forward is to reinitialize the drive and destroy all data, which is not acceptable.
Comment 1 Zach Carter 2010-10-24 01:26:54 EDT
Created attachment 455306 [details]
output of vgdisplay -v
Comment 2 Zach Carter 2010-10-24 01:27:20 EDT
Created attachment 455307 [details]
Output of fdisk -l
Comment 3 Zach Carter 2010-10-24 01:50:20 EDT
Created attachment 455308 [details]
storage.log
Comment 4 Zach Carter 2010-10-24 01:50:49 EDT
Created attachment 455309 [details]
program.log
Comment 5 Zach Carter 2010-10-24 01:51:11 EDT
Created attachment 455310 [details]
anaconda.log
Comment 6 David Lehman 2010-10-25 13:52:45 EDT
We use parted for all partition-table operations. Please run 'parted -l' and attach the output to this bug report.
Comment 7 Zach Carter 2010-10-25 14:10:59 EDT
(In reply to comment #6)
> We use parted for all partition-table operations. Please run 'parted -l' and
> attach the output to this bug report.

Ok, I can do this as soon as I get home tonight, about 6PM Pacific time.
Comment 8 Zach Carter 2010-10-25 21:08:32 EDT
Created attachment 455655 [details]
The output of "parted -l"
Comment 9 James Laska 2010-10-26 09:31:07 EDT
(In reply to comment #8)
> Created attachment 455655 [details]
> The output of "parted -l"

The parted output supplied doesn't show /dev/sdd .  However I do see a message indicating ...

No Implementation: Partition 3 isn't aligned to cylinder boundaries.  This is still unsupported.

I suspect that's complaining about /dev/sdd3 not being properly aligned?
Comment 10 Zach Carter 2010-10-26 12:57:19 EDT
Grr....I don't recall how the partition table for this disk got into this state, but it seems lame that the OS can recognize and mount it just fine but parted and anaconda won't scan it, especially since parted specifically allows you to create partitions that are not aligned on cylinder boundaries.

"  -a, --align=[none|cyl|min|opt]  alignment for new partitions"
Comment 11 David Lehman 2010-10-26 13:47:23 EDT
Alignment to cylinder boundaries is not a real requirement of parted, anaconda, or the OS. In fact, anaconda does not make any effort at all to create cylinder-aligned partitions.

Perhaps we can learn a little more if you run this:

  parted /dev/sdd print
Comment 12 Zach Carter 2010-10-26 22:03:47 EDT
Created attachment 455899 [details]
The output of "parted /dev/sdd print"
Comment 13 Zach Carter 2010-10-26 22:06:59 EDT
Nothing new in "parted /dev/sdd print".

The classic "fdisk -l /dev/sdd produces" more informational output (see fdisk -l attachment).

Here is "sfdisk -l /dev/sdd":

Disk /dev/sdd: 91201 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sdd1          0+     64      65-    522081   83  Linux
/dev/sdd2         65     326     262    2104515   82  Linux swap / Solaris
/dev/sdd3        327   91200   90874  729945405   8e  Linux LVM
/dev/sdd4          0       -       0          0    0  Empty
Comment 14 Zach Carter 2010-10-26 22:11:56 EDT
The empty "sdd4" partition looks interesting.  I have no idea how it got there.
Comment 15 Brian Lane 2010-11-10 17:47:11 EST
It looks like parted thinks your /dev/sdd is pc98 for some reason. Could you make a copy of the MBR (dd if=/dev/sda of=sdd.mbr.bin bs=512 count=1) and attach it here?
Comment 16 Brian Lane 2010-11-10 18:10:07 EST
Just to be clear:

dd if=/dev/sdd of=sdd.mbr.bin bs=512 count=1
Comment 17 Zach Carter 2010-11-13 01:04:03 EST
Created attachment 460198 [details]
contents of mbr
Comment 18 Brian Lane 2010-11-16 14:31:10 EST
Thanks. Looks like I need the next sector as well, when it falls into the pc98 test it also checks for what it thinks are pc98 partitions in sector 2.

dd if=/dev/sdd of=sdd.mbr.bin bs=512 count=2
Comment 19 Zach Carter 2010-11-18 23:07:49 EST
Created attachment 461453 [details]
MBR plus additional sector
Comment 20 Zach Carter 2011-05-14 14:04:52 EDT
Update: I reproduced this with F15 Final RC3 this morning.
Comment 21 Drunkard Zhang 2011-06-15 03:00:55 EDT
"dd if=/dev/zero of=/dev/sdj bs=512 count=8" can resolve this temporarily.
Comment 22 Zach Carter 2011-09-02 12:34:42 EDT
Still a problem on the F16 Alpha

I'm probably going to repartition this drive soon, which means I'll no longer be able to reproduce the bug.   If you want me to gather any debug info before doing that, please let me know.
Comment 23 Brian Lane 2011-09-02 13:13:38 EDT
I haven't changed anything related to pc98 detection yet so that isn't a surprise. I think I've got everything I need, thanks!
Comment 24 Brian Lane 2011-10-07 20:12:00 EDT
Could you give this build a try? It should install fine on f16.

http://koji.fedoraproject.org/koji/taskinfo?taskID=3413162
Comment 25 Fedora Update System 2011-10-11 14:31:50 EDT
parted-3.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/parted-3.0-3.fc16
Comment 26 Zach Carter 2011-10-14 00:03:11 EDT
Verified:  parted-3.0-3.fc16 is able to read my drive with no trouble.

Thanks!
Comment 27 Fedora Update System 2011-10-14 16:17:41 EDT
parted-2.3-11.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/parted-2.3-11.fc15
Comment 28 Fedora Update System 2011-10-14 19:02:02 EDT
parted-2.3-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/parted-2.3-5.fc14
Comment 29 Fedora Update System 2011-10-15 16:28:26 EDT
Package parted-2.3-5.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parted-2.3-5.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14410
then log in and leave karma (feedback).
Comment 30 Fedora Update System 2011-10-15 20:56:40 EDT
parted-3.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Fedora Update System 2011-12-03 21:41:33 EST
parted-2.3-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2011-12-03 21:46:03 EST
parted-2.3-11.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.