Bug 646082 - iwlagn: Received BA when not expected .. Regression on .36
iwlagn: Received BA when not expected .. Regression on .36
Status: CLOSED DUPLICATE of bug 648732
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-24 06:10 EDT by Jóhann B. Guðmundsson
Modified: 2011-01-12 08:16 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-12 08:16:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2010-10-24 06:10:49 EDT
Description of problem:

We seemed to be hitting a regression with .36

Dmesg is flooded with: iwlagn : Received BA when not expected

Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Version-Release number of selected component (if applicable):

2.6.36-1.fc15.x86_64

How reproducible:

Always 

Steps to Reproduce:
1. Boot and wait establish a wireless connection.
2.
3.
  
Actual results:

The above

Expected results:

No iwlagn errors 

Additional info:
Comment 1 Jóhann B. Guðmundsson 2010-10-24 06:23:41 EDT
Further digging reveals that this is most likely a uCode firmware bug that seems to be affecting a series of Intel cards so I guess 4965 can be added to that list. 

See https://bugzilla.kernel.org/show_bug.cgi?id=16691 for details 

This is the firmware I got installed.

/lib/firmware/iwlwifi-4965-1.ucode
/lib/firmware/iwlwifi-4965-2.ucode

iwlwifi-4965-2.ucode is what's being shipped in iwlwifi-4965-ucode-228.61.2.24 which is the latest available for this card on http://intellinuxwireless.org/?n=Downloads
Comment 2 Stanislaw Gruszka 2010-12-01 04:55:51 EST
If this cause some functional problem, this workaround should help:

echo "options iwlagn 11n_disable50=1 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf
Comment 3 Stanislaw Gruszka 2011-01-12 08:16:40 EST

*** This bug has been marked as a duplicate of bug 648732 ***

Note You need to log in before you can comment on or make changes to this bug.