Bug 64613 - Non ASCII text files seen as raw data
Non ASCII text files seen as raw data
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 12:53 EDT by Hannu Teulahti
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 10:39:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hannu Teulahti 2002-05-08 12:53:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
ISO-8859 text goes to postscript printer as raw data.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a postscript printer queue
2. print ISO-8859-1 text (scandinavian, with umlauts [edvEDV]) to queue
3.
	

Actual Results:  Text prints with stair stepping, 8bit characters are all 
wrong.


Expected Results:  Page printed correctly

Additional info:

# file *
ascii_text_file:   ASCII text
iso8859_text_file: ISO-8859 text

I tried to make a dummy printer with a file as the printer device. 7bit ascii 
text prints correctly as postscript, but 8bit ISO-8859 goes right trough 
without any formatting/filtering.

Old printtool based queues have always worked correctly
(RH Linux <= 7.1)
Comment 1 Tim Waugh 2004-12-10 10:39:46 EST
With CUPS you can use "-o charset=..." to deal with this sort of thing.

Note You need to log in before you can comment on or make changes to this bug.