Bug 646171 (CVE-2009-5012) - CVE-2009-5012 pyftpdlib: Ability to list the root directory via an FTP session
Summary: CVE-2009-5012 pyftpdlib: Ability to list the root directory via an FTP session
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2009-5012
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 646178
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-24 19:09 UTC by Jan Lieskovsky
Modified: 2019-09-29 12:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-22 15:28:05 UTC


Attachments (Terms of Use)

Description Jan Lieskovsky 2010-10-24 19:09:41 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2009-5012 to
the following vulnerability:

ftpserver.py in pyftpdlib before 0.5.2 does not require the l
permission for the MLST command, which allows remote authenticated
users to bypass intended access restrictions and list the root
directory via an FTP session.

References:
[1] http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-5012
[2] http://code.google.com/p/pyftpdlib/issues/detail?id=114
[3] http://code.google.com/p/pyftpdlib/source/browse/trunk/HISTORY
[4] http://code.google.com/p/pyftpdlib/source/detail?r=596
[5] http://code.google.com/p/pyftpdlib/source/diff?spec=svn596&r=596&format=side&path=/trunk/pyftpdlib/ftpserver.py

Affected versions:
This issue affects the version of the pyftpdlib package, as shipped
with Fedora release of 12.

This issue does NOT affect the version of the pyftpdlib package, as
shipped with Fedora release of 13 (relevant code part is already
updated).

Comment 1 Jan Lieskovsky 2010-10-24 19:44:10 UTC
Created pyftpdlib tracking bugs for this issue

Affects: fedora-12 [bug 646178]


Note You need to log in before you can comment on or make changes to this bug.