Bug 64629 - No Local CD-ROM option when installing
No Local CD-ROM option when installing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 16:18 EDT by Magnus Sandin
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-13 01:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Sandin 2002-05-08 16:18:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
On my Compaq ML-330 with an integrated ATA-100 RAID controller I don't get the
option to install from the local CD-ROM drive (even if I have booted from the
CD-ROM). I get the intall from FTP and HTTP etc. but not the CD_ROM option.

I tried RedHat 7.2 which works fine (the option is displayed and works)

I tried the 7.3 CD on my notebook and it seems to work fine there, strange?



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Get a Compaq ML-330 2x20GB disks RAID-1
2.Boot the RedHat installation CD-1
3.
	

Actual Results:  I can only select to install from FTP, HTTP, NFS, Local
HardDrive... 

Expected Results:  I should also get the option to select to install from the
CD-ROM drive that I have booted from.

Additional info:
Comment 1 Michael Fulbright 2002-05-09 14:26:32 EDT
Are you sure that the ATA-100 interface supports having a CDROM drive attached?
Does it work if you put the CDROM on a non-ATA-100 interface?
Comment 2 Magnus Sandin 2002-05-09 15:43:01 EDT
The CD-ROM drive is not attached to the ATA-100 RAID controller...

However, as I described in the bug report, RedHat 7.2 works, and I can install
from the CD-ROM...
Comment 3 Michael Fulbright 2002-05-13 15:22:44 EDT
If you look on VC4 (cntl-alt-f4) do you see any read errors?  It would appear in
the drive in the system in question that the loader is unable to see the files
it expects to see, so the option to install from CD is not offered.  This is on
a different part of the CD than the boot files the BIOS uses to boot the loader.
Comment 4 Magnus Sandin 2002-05-15 05:15:07 EDT
When I boot up the RedHat installation I can se that the IDE driver find my two
disks at: hda and hdc. The CD-ROM is detected as hde.

When I get to the option where I would like to see "Local CD-ROM" as an install
option, then I switch to Cosole-4 (Alt + F4) and I can see information from
NET4, SCSI, USB etc...

Then I see information from the network drivers (I have 1 x eepro100 and 4 x
tulip based cards).

There is nothing about read errors or any other error information, just common
information. example:

<6>Linux Tulip driver version 0.9.15-pre10 (Mar 8, 2002)
<6>tulip0:   EEPROM default media type Autosence.
<6>tulip0:   Index #0 - Media MII (#11) described by a 21142 MII PHY (3) block.

etc.
Comment 5 Michael Fulbright 2002-06-12 12:11:40 EDT
I do not have this particular hardware available so I can't reproduce the issue.
A possible workaround is to copy the CD images onto your harddrive and do a
harddrive install.  If you have linux installed on the system already this is
not difficult to do.

Is that an option?
Comment 6 Magnus Sandin 2002-06-13 01:18:05 EDT
Well, we decided to not use RedHat 7.3.

We use RedHat 7.2 instead which works just fine.
Comment 7 Michael Fulbright 2002-06-20 11:53:59 EDT
Ok please let us know if you have any further problems.

Note You need to log in before you can comment on or make changes to this bug.