Bug 6463 - kudzu doesn't rescan scsi bus after detecting controller
kudzu doesn't rescan scsi bus after detecting controller
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
6.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-28 10:41 EDT by Bob Drzyzgula
Modified: 2014-03-16 22:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 17:40:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Drzyzgula 1999-10-28 10:41:51 EDT
Hi. I installed RH6.1 from a CD burned from the ISO image
downloaded from your site a week or so ago. The original
build only had an AIC7895 SCSI Controller (Tyan Thuder
Dual, with 440LX chipset). I later installed a DPT PM3334UW
(I was having trouble with an external chain off the
Adaptec, which I must say has been no end of trouble to
me...).

What happened was that while kudzu properly identified the
new device as a DPT controller, its pci mapping table
specifies the wrong driver; it lists "dpt", when there is
no module called "dpt". The proper entry should be "eata".
Once I changed that, kudzu worked properly.

The other problem I had was that, since your setup by
default loads the SCSI driver modules in the initrd, and
since when a new controller is added the initrd isn't
updated, kudzu had trouble with the drives attached to the
controller. If I ran kudzu by hand and then rebooted, kudzu
would be happy about the DPT controller (as long as I had
fixed the pcitable), but it would tell me that the drives
had been removed from the system. Once I edited the initrd
to autoload the eata driver as well as the AIC driver,
everything was fine and dandy.

So, I think that the things that need to be fixed are (a)
the pcitable, and (b), ultimately I think that if kudzu
identifies a new SCSI controller you should be providing a
facility to automatically update the initrd (assuming that
you are trying to avoid the need for people to compile new
kernels.).

Following is a link to a thread on Deja.com, where I
reported this problem in case others experience the same
thing; there's a little more detail in there:

http://www.deja.com/viewthread.xp?AN=541265448

Thanks,
--Bob Drzyzgula
bob@drzyzgula.org

------- Additional Comments From   10/28/99 10:43 -------
(Note that I also sent this to bugs@redhat.com, and came to
file it here because of the "deprecated" autoresponse from
the former address...)

--Bob
Comment 1 Bill Nottingham 1999-10-28 11:25:59 EDT
The pci id mapping problem is fixed in the latest kudzu in
Raw Hide.

The second one is something we definitely need to work on
clearing up...
Comment 2 Bob Drzyzgula 1999-10-28 15:10:59 EDT
(Note that I also sent this to bugs@redhat.com, and came to
file it here because of the "deprecated" autoresponse from
the former address...)

--Bob
Comment 3 Brent Fox 2002-06-04 21:12:01 EDT
notting, do we update the initrd correctly now?
Comment 4 Bill Nottingham 2002-06-04 21:31:55 EDT
No, mkinitrd is not re-run...
Comment 5 Bill Nottingham 2005-02-04 17:40:56 EST
Closing out bugs from older, no longer supported releases. Apologies for the
lack of response.

Note You need to log in before you can comment on or make changes to this bug.