Bug 646401 - Error popup on selection affected systems of an errata (Regression)
Error popup on selection affected systems of an errata (Regression)
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
540
Unspecified Linux
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Garik Khachikyan
: Regression
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-10-25 06:11 EDT by Garik Khachikyan
Modified: 2015-01-04 16:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On the "Affected Systems" page, clicking the "Select All" checkbox caused a pop-up error to appear. This no longer occurs, and clicking the above checkbox now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 10:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2010-10-25 06:11:27 EDT
Description of problem:
When on the selected errata one refers to the "Affected Systems" and wishes to "Select All" of them and apply action(s) in SSM, then during press of checkbox for selecting them all, raises a popup error:
---
resp is undefined (Firefox)
Cannot read property 'header' of undefined (Google Chrome)
---
Selecting the systems one by one is okey. (but imagine doing this on thousands)

Version-Release number of selected component (if applicable):
Current latest sat540 stage-signed iso (Satellite-5.4.0-RHEL5-re20101025.0-x86_64.iso)

How reproducible:
always on clicking the "Select All" checkbox. 

Steps to Reproduce:
1. select an errata which has at least 2 systems to be applied.
2. refer to the "Affected Systems" page of that errata (https://<sat>/rhn/errata/details/SystemsAffected.do?eid=<errataID>)
3. click at the checkbox intended for "Select All"
  
Actual results:
unexpected popup (see above)

Expected results:
No popups, normal select-all should proceed.

Additional info:
Comment 1 Garik Khachikyan 2010-10-25 06:12:25 EDT
it's a regression - the one on satellite 530+ is ok.
Comment 2 Tomas Lestach 2010-11-18 08:40:50 EST
Hey Garik,
I tried your reproducer and do not see any unexpected popups. Getting only expected behavior. Could you check if the reproducer is complete, please or try it on a different machine?
Comment 9 Garik Khachikyan 2010-12-10 08:00:41 EST
# VERIFIED

Packages fixing the issue are:
---
spacewalk-java-1.2.39-34.el5sat
spacewalk-java-oracle-1.2.39-34.el5sat
spacewalk-java-config-1.2.39-34.el5sat
spacewalk-java-lib-1.2.39-34.el5sat
spacewalk-taskomatic-1.2.39-34.el5sat
---

Checked on following packages:
Firefox; Google Chrome; Opera - all is fine now with the "Select all" checkbox click/unclick under "https://<sat>/rhn/errata/details/SystemsAffected.do?eid=<eid>" link.
Comment 11 errata-xmlrpc 2010-12-16 10:45:12 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0991.html
Comment 12 Jaromir Hradilek 2010-12-16 11:34:34 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
On the "Affected Systems" page, clicking the "Select All" checkbox caused a pop-up error to appear. This no longer occurs, and clicking the above checkbox now works as expected.

Note You need to log in before you can comment on or make changes to this bug.