Bug 646437 - Fail to login to desktop after preupgrading to F14 from F12
Fail to login to desktop after preupgrading to F14 from F12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks: F14-accepted/F14FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2010-10-25 08:30 EDT by He Rui
Modified: 2010-11-02 11:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.9.7-7.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-01 16:51:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description He Rui 2010-10-25 08:30:16 EDT
Description of problem:
Preupgraded from F12 to F14, and found out that desktop login was failed as it kept restart when entering password and clicking 'login'. This is probably due to the selinux, since if selinux=0 was passed, login was normal. 

Version-Release number of selected component (if applicable):
selinux-policy-3.9.7-3.fc14.noarch
selinux-policy-targeted-3.9.7-3.fc14.noarch

How reproducible:
100%

Steps to Reproduce:
1. http://fedoraproject.org/wiki/QA:Testcase_Preupgrade_from_older_release
2. Try to login after installation finished and rebooted.


Additional info:
When enabled updates-testing and updated to: 

selinux-policy-3.9.7-4.fc14.noarch
selinux-policy-targeted-3.9.7-4.fc14.noarch

Selinux automatically relabelled and rebooted, login then went well.
Comment 1 James Laska 2010-10-25 09:50:21 EDT
Good find, and follow-up testing using 'updates-testing'.  I've added positive karma to the bodhi selinux-policy update as a result of your testing (see https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-4.fc14).  Let's see if we can get some more feedback so that selinux-policy package is pushed into 'updates'.

I'm moving this to MODIFIED based on your input that selinux-policy-3.9.7-4 resolves this issue.  

dwalsh: Would it make sense to add this bug to the proposed bodhi update https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-4.fc14
Comment 2 He Rui 2010-10-26 05:44:51 EDT
What is weird is that the fresh installed system and preupgraded system from F-13 also use selinux version 3.9.7-3, but the login of them work every time, why? I only see this happening when preupgrading from F-12(older release). So I'm not very sure if this issue can be fixed when 3.9.7-4 is pushed to stable.
Comment 3 James Laska 2010-10-26 10:39:10 EDT
(In reply to comment #2)
> What is weird is that the fresh installed system and preupgraded system from
> F-13 also use selinux version 3.9.7-3, but the login of them work every time,
> why? I only see this happening when preupgrading from F-12(older release). So
> I'm not very sure if this issue can be fixed when 3.9.7-4 is pushed to stable.

I just finished 2 F-12 (plus updates) -> F-14-RC1 preupgrade tests and I was able to login without error after upgrade.  The package selinux-policy-3.9.7-3.fc14 is installed on both my tests (i386 and x86_64).

My test user was a local user without a password (useradd -p '' guest).  I should have tried with a password as well.  Was there anything special about the user account in your test (local, krb, ldap etc...)?
Comment 4 He Rui 2010-10-26 22:46:18 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > What is weird is that the fresh installed system and preupgraded system from
> > F-13 also use selinux version 3.9.7-3, but the login of them work every time,
> > why? I only see this happening when preupgrading from F-12(older release). So
> > I'm not very sure if this issue can be fixed when 3.9.7-4 is pushed to stable.
> 
> I just finished 2 F-12 (plus updates) -> F-14-RC1 preupgrade tests and I was
> able to login without error after upgrade.  The package
> selinux-policy-3.9.7-3.fc14 is installed on both my tests (i386 and x86_64).
> 
> My test user was a local user without a password (useradd -p '' guest).  I
> should have tried with a password as well.  Was there anything special about
> the user account in your test (local, krb, ldap etc...)?

I think you should try one account with a password. There was nothing special about my user account which was created on F-12 by firstboot. And on the F-12 system, before preupgrading, I didn't do a fully update since installed. Will run more tests to verify it.
Comment 5 Fedora Update System 2010-10-28 16:13:20 EDT
selinux-policy-3.9.7-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-7.fc14
Comment 6 Fedora Update System 2010-10-29 16:39:36 EDT
selinux-policy-3.9.7-7.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-7.fc14
Comment 7 He Rui 2010-10-31 23:18:27 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > What is weird is that the fresh installed system and preupgraded system from
> > > F-13 also use selinux version 3.9.7-3, but the login of them work every time,
> > > why? I only see this happening when preupgrading from F-12(older release). So
> > > I'm not very sure if this issue can be fixed when 3.9.7-4 is pushed to stable.
> > 
> > I just finished 2 F-12 (plus updates) -> F-14-RC1 preupgrade tests and I was
> > able to login without error after upgrade.  The package
> > selinux-policy-3.9.7-3.fc14 is installed on both my tests (i386 and x86_64).
> > 
> > My test user was a local user without a password (useradd -p '' guest).  I
> > should have tried with a password as well.  Was there anything special about
> > the user account in your test (local, krb, ldap etc...)?
> 
> I think you should try one account with a password. There was nothing special
> about my user account which was created on F-12 by firstboot. And on the F-12
> system, before preupgrading, I didn't do a fully update since installed. Will
> run more tests to verify it.

I've verified that if I did a full update on F-12 before preupgrade, this issue would not happen and if I didn't, it would. So it doesn't matter what version it will be upgraded to. Is it due to relabel or something else?
Comment 8 Kamil Páral 2010-11-01 09:11:51 EDT
I just did clean F12 installation from Live x86_64 media, updated just preupgrade+python-urlgrabber, and then upgraded to F14 using preupgrade. After upgrade finished and computer rebooted, the GDM won't come up (and HAL daemon probably failed to start). Rebooting with selinux=0 fixed the issue. Another reboot triggered selinux relabeling process and after that GDM works even with selinux enabled.

Clearly the selinux version downloaded by preupgrade is ok, but it needed to relabel files, which was not performed automatically.

F14 is final already, proposing as CommonBugs. As rhe reported, full system update of F12 before using preupgrade should be sufficient to avoid this issue.
Comment 9 Kamil Páral 2010-11-01 09:20:25 EDT
(In reply to comment #8)
> F14 is final already,

Oh, this has nothing to do with F14 being final, right? We can still fix this by issuing an update of selinux-policy that preupgrade will download instead of the current one, right?

So, how can I test preupgrade with selinux-policy that's currently in updates-testing. Is there a way how to do that?
Comment 10 James Laska 2010-11-01 11:20:32 EDT
https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-7.fc14 will be in F-14-updates and available for preupgraders.  Please add appropriate karma.
Comment 11 James Laska 2010-11-01 12:29:48 EDT
I have attempted to document this issue, and the known workaround at https://fedoraproject.org/wiki/Common_F14_bugs#f12_preupgrade

Please feel free to correct/adjust as needed.  Thanks!
Comment 12 Fedora Update System 2010-11-01 16:50:46 EDT
selinux-policy-3.9.7-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Kamil Páral 2010-11-02 11:46:36 EDT
I can confirm that fully updated F12 does not have any issue when preupgrading to F14. F12 has issues and this update did not help, because (as I learned) preupgrade only downloads packages from base repository, not from updates repo. I'll update CommonBugs page accordingly.

Note You need to log in before you can comment on or make changes to this bug.