Bug 646485 - Replace SETUID in spec file with the correct file capabilities.
Replace SETUID in spec file with the correct file capabilities.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: polkit (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: removesuid16
  Show dependency treegraph
 
Reported: 2010-10-25 09:34 EDT by Daniel Walsh
Modified: 2013-03-05 23:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 646443
Environment:
Last Closed: 2011-04-05 12:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2010-10-25 09:34:48 EDT
+++ This bug was initially created as a clone of Bug #646443 +++

Description of problem:

Please remove setuid setup of files in your package with file capabilities.

This is to satisfy the F15 feature.

https://fedoraproject.org/wiki/Features/RemoveSETUID

An example of how this was done for X is.


%if 0%{?fedora} < 15
%define Xorgperms %attr(4711, root, root)
%else
%define Xorgperms %attr(0711,root,root) %caps(cap_sys_admin,cap_sys_rawio,cap_dac_override=pe)
%endif
Comment 1 Daniel Walsh 2011-04-05 09:19:14 EDT
Any movement on this?
Comment 2 David Zeuthen 2011-04-05 12:25:56 EDT
Pretty much the same as what Colin said in bug 646450 comment 2. E.g. pkexec(1) is used to launch arbitrary programs so it needs to have all the capabilities anyway... so removing its setuid bit and replacing it with file capabilities doesn't buy anything and actually might just give a false sense of security since e.g. "hardening" scripts scanning for setuid helpers might miss it....
Comment 3 Daniel Walsh 2011-04-05 12:38:16 EDT
Ok then lets close it WONT FIX.

Note You need to log in before you can comment on or make changes to this bug.