Bug 64649 - Sound, Power Management do not work. Standard install installs wrong power management driver.
Sound, Power Management do not work. Standard install installs wrong power m...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 22:19 EDT by Aaron Freed
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 22:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Freed 2002-05-08 22:19:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
Default installation identifies the Sony PCG-GRX570 Laptop as supporting APM when, in fact, it supports ACPI.  APM, therefore, does not work at all.  Sound board is (incorrectly?) identified as Intel i810 AC'97, when it is actually an AC-XG (or possibly a "Sound MAX").  Sound works poorly, full of dropouts and pops, if at all.  If full-duplex mode is enabled, a "FATAL ERROR: CPU Overload, Aborting" message appears and no sound is heard.

USB seems to work, though limited testing suggests that it is unstable.

It has been noted that the following are the devices assigned to IRQ 9:  usb-uhci, usb-uhci (2 USB ports), Intel ICH3, eth0.
Thus suggest that, in addition to the cascade from IRQ2, IRQ9 is handling the soundcard, ethernet card, at least two USB ports, and ACPI.

I believe that it is this long list of devices competing for IRQ9 that is at the root of these problems.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Standard install of Linux 7.3 on Sony PCG-GRX570 (Or IBM NetVista Pentium 4-based PC.  See BUG 64005.)
2. Try to play sound or invoke power management.  Sound, if any is produced at all, is of poor quality, filled with dropouts, pauses, pops and hisses.  Try to check battery status.  Even when the system is running on the battery, APM reports it is "on line, no battery installed"  Compiling a kernel with ACPI (but no APM) support has not produced any different result from the above with RHAD 7.2, Kernel 2.4.9-31 or 2.4.18.  I have not tried it yet with the new kernel included with 7.3.  

Limited testing with USB seems to suggest that USB devices lock up easily, or simply fail to operate. (I haven't any of my own--had to borrow one to test it.)

 

Actual Results:  See above.  Results are described there.  Also:  Occasionally if attempts are made to access the sound device in Full Duplex mode and with network transparency, the machine (or at least KDE) will LOCK UP to the point of requiring a hard reboot.  Also, Also:  Since power management does not work, the machine will continue running at full power, even when on battery, until the battery is drained.  No orderly shutdown or power-fail warning is ever issued, so the result is, essentially, the same as that which would be encountered upon unplugging a standard server or workstation from its power without first shutting it down.

Expected Results:  I had hoped for quality sound and power management on what is otherwise a fantastic and amazingly stable and fast laptop for running Linux.

Additional info:

Machine is an UNMODIFIED STOCK Sony Vaio PCG GRX570 Laptop based upon the Pentiun 4 at 1.6 GHz and, evidently the same Intel i8XX chipset as is used in the IBM NETVISTA described in Bug 64005.
512 MB RAM Standard
16.1" Display at 1600 by 1200 by 24-bit
ATI Radion 7500 "M7" Mobility
NO FLOPPY DRIVE
CD-RW/DVD-ROM combo
40 GB (formatted at 38.5) GB hard drive.
NO PCI cards
Integrated ICH3 Intel Chipset.
Comment 1 Michael K. Johnson 2002-05-16 16:44:11 EDT
ACPI support in Linux does not yet work well enough generically for
us to enable in Red Hat Linux.  APM is the only power management
that we support at this time.

This is two bugs in one report; I'm closing this one as "NOTABUG"
becuase ACPI is not available to be enabled.

You can open a separate bug for the sound quality issues if you
like.  Include lspci -vxxx and lsmod output if you do so.

Note You need to log in before you can comment on or make changes to this bug.