Bug 64650 - Upgrade from 7.2 fails
Upgrade from 7.2 fails
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 22:45 EDT by George Thomas
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 08:18:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Thomas 2002-05-08 22:45:18 EDT
Description of Problem:
Upgrade from 7.2 to 7.2 fails installing ksebase
Fails because /usr/share/config/kdm used to be a directory and is now a symlink

Version-Release number of selected component (if applicable):


How Reproducible:
100% on the systems I tried

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Michael Fulbright 2002-05-13 14:54:56 EDT
>Upgrade from 7.2 to 7.2 fails installing ksebase

I'm assuming you mean 7.2 to 7.3.

I have not seen this issue and I've run 7.2 to 7.3 everything upgrades.  Were
you running the kdebase that shipped with 7.2?
Comment 2 George Thomas 2002-05-13 16:07:05 EDT
I had this same behaviour on multiple systems, each of which started life
probably as 6.2 hoxes, updated to 7, 7.1 & 7.2 as they came available.

I never did anything special (KDE-wise) to any of them.
Comment 3 bastiaan 2002-05-13 19:25:46 EDT
I experienced this problem on my desktop box which, if I recall correctly,
started fresh with RH7. 
The /usr/share/config/kdm directory contained a symlink kdmrc to
../../../../etc/X11/xdm/kdmrc
Comment 4 Adam Pribyl 2002-05-16 13:35:19 EDT
I had same behaviour on box which was first time installed with 7.1.93 beta 7.2,
then upgraded to 7.2 then to 7.3.

The message and state of install proces after failure of instalation of kdebase
makes me really busy for whole afternoon, finaly I choose to install instead of
upgrade and I did not find the cause like people above (hard to find something
when you can access only single mode...
Comment 5 Katherine Holcomb 2002-06-13 17:09:46 EDT
Here's another "me too."  I've attempted to upgrade four machines from 7.2 to
7.3 and three have failed; two with the kdebase problem and the other was an
error I do not recall (I did not note it at the time).  All four had had a fresh
installation as of 7.0 or later.  Mysteriously, one of the four succeeded. I
think it may have had an installation of 7.2, not an upgrade from an earlier
release.

The failure leaves the machine in a munged state. Reinstalling from scratch can
be a big pain on machines at work that have a lot of customized config files. 
It's less of an issue for my home machines, but it's still a serious problem.
Comment 6 Petr Rockai 2005-03-22 08:18:20 EST
Suppose this isn't really relevant anymore... Shout if i am mistaken. 

Note You need to log in before you can comment on or make changes to this bug.