Bug 64651 - Anaconda Crash
Anaconda Crash
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 23:24 EDT by Dan Egli
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-12 16:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Dump (120.28 KB, text/plain)
2002-05-08 23:27 EDT, Dan Egli
no flags Details

  None (edit)
Description Dan Egli 2002-05-08 23:24:58 EDT
Description of Problem: Tried to upgrade from 7.2 to 7.3


Version-Release number of selected component (if applicable): 7.3-7

Actual Results: Upgrade Crashed after all components installed, when trying to 
update boot loader (Dump log below shows trying to run Lilo, but I use Grub!)


Expected Results: Successful upgrade.


Additional Information:
Anaconda Dump:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/bootloader.py", line 893, in writeBootloader
    justConfigFile, intf)
  File "/usr/lib/anaconda/bootloader.py", line 732, in write
    justConfig | (self.useGrubVal))
  File "/usr/lib/anaconda/bootloader.py", line 651, in writeLilo
    catchfd = 2, closefd = 1)
  File "/usr/lib/anaconda/iutil.py", line 118, in execWithCapture
    raise RuntimeError, command + " can not be run"
RuntimeError: /mnt/sysimage/sbin/lilo can not be run


Complete log file attached to bug.
Comment 1 Dan Egli 2002-05-08 23:27:57 EDT
Created attachment 56764 [details]
Anaconda Dump
Comment 2 Michael Fulbright 2002-05-09 14:23:58 EDT
Please boot the installer with the 'linux mediacheck' option and test your CDs.
They appear to be bad.
Comment 3 Dan Egli 2002-05-10 01:41:35 EDT
The CDs are very doubtful to be bad because I have successfully used them 
installing other machines. And they were burned from ISO files that had the 
exact same MD5 sum as was listed on your ftp site.

I will try MediaCheck next time I use them, but I don't think it is a bad CD.

Comment 4 Michael Fulbright 2002-05-10 11:50:00 EDT
Different CD drives handle media differently in my experience with hundreds of
bug reports :(

Let us know if mediacheck passes on the system in question.
Comment 5 Dan Egli 2002-05-28 14:17:59 EDT
Sorry to take so long in getting back. I ran MediaCheck and all three discs 
passed the test. This WAS on the machine that had problems.
Comment 6 Michael Fulbright 2002-06-12 12:52:19 EDT
Thank you for testing the CDs - will assign to an engineer.
Comment 7 Jeremy Katz 2002-06-12 12:57:12 EDT
During the upgrade, did the bootloader screen say that it had detected grub or
lilo?  Also, what do your lilo.conf and grub.conf look like?
Comment 8 Dan Egli 2002-06-12 16:46:53 EDT
Answer 1) Lilo was detected, but I selected the option to replace with grub. 
There was no grub.conf before that time since lilo was in use. Lilo.conf was 
something similiar to the following (reconstructed from memory and looking at 
another lilo.conf, I am not physically at the machine in question and since 
it's a stand alone, I cannot access it remotely to look at the real one)

prompt
timeout=30
default=linux
boot=/dev/hde
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.7-10
        label=failsafe
        initrd=/boot/initrd-2.4.7-10.img
        read-only
        root=/dev/hde6

image=/boot/vmlinuz-2.4.18
       label=linux
       initrd=/boot/initrd-2.4.18.img
       read-only
       root=/dev/hde6
Comment 9 Jeremy Katz 2002-07-02 01:06:11 EDT
Okay, I've added some sanity checking to the code in CVS to try to ensure this
doesn't happen in the future

Note You need to log in before you can comment on or make changes to this bug.