Bug 646565 - yum repolist all fails after subscribing to a pool On Premises
Summary: yum repolist all fails after subscribing to a pool On Premises
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
high
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-10-25 17:32 UTC by John Sefler
Modified: 2013-01-10 10:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:42:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description John Sefler 2010-10-25 17:32:57 UTC
Description of problem:
yum repolist all fails after subscribing to a pool On Premises

Version-Release number of selected component (if applicable):
[root@jsefler-rhel6-client01 pki]# rpm -q subscription-manager
subscription-manager-0.93.0-1.git.60.65c1da8.fc12.i386
[root@jsefler-f12-candlepin candlepin]# git show-ref master
262ed34fb883b8f57fe040bdd108ab9153ac5e51 refs/heads/master
262ed34fb883b8f57fe040bdd108ab9153ac5e51 refs/remotes/origin/master




Steps to Reproduce:
[root@jsefler-rhel6-client01 pki]# subscription-manager-cli register --username=testuser1 --password=password
9f8e117a-5a64-4a63-9de6-e67bfb49094b testuser1
[root@jsefler-rhel6-client01 pki]# yum repolist all
Loaded plugins: refresh-packagekit, rhnplugin, rhsmplugin
Updating Red Hat repositories.
INFO:repolib:repos updated: 0
This system is not registered with RHN.
RHN support will be disabled.
repo id                                              repo name                                                                                         status
rhel-beta                                            Red Hat Enterprise Linux 5.90Server Beta - x86_64                                                 disabled
rhel-beta-debuginfo                                  Red Hat Enterprise Linux 5.90Server Beta - x86_64 - Debuginfo                                     disabled
rhel-beta-optional                                   Red Hat Enterprise Linux 5.90Server Beta (Optional) - x86_64                                      disabled
rhel-beta-optional-debuginfo                         Red Hat Enterprise Linux 5.90Server Beta (Optional) - x86_64 - Debuginfo                          disabled
rhel-beta-optional-source                            Red Hat Enterprise Linux 5.90Server Beta (Optional) - x86_64 - Source                             disabled
rhel-beta-source                                     Red Hat Enterprise Linux 5.90Server Beta - x86_64 - Source                                        disabled
rhel-clustered-storage-beta                          Red Hat Enterprise Linux 5.90Server Clustered Storage Beta - x86_64                               disabled
rhel-high-availability-beta                          Red Hat Enterprise Linux 5.90Server High Availability Beta - x86_64                               disabled
rhel-large-filesystem-beta                           Red Hat Enterprise Linux 5.90Server Large Filesystem Beta - x86_64                                disabled
rhel-load-balance-beta                               Red Hat Enterprise Linux 5.90Server Load Balance Beta - x86_64                                    disabled
repolist: 0
[root@jsefler-rhel6-client01 pki]# subscription-manager-cli list --available | grep PoolId
PoolId:            	ff8080812be40338012be40473fb00cb
PoolId:            	ff8080812be40338012be40474f500d0
PoolId:            	ff8080812be40338012be404750200d1
PoolId:            	ff8080812be40338012be404751900d2
PoolId:            	ff8080812be40338012be404748200cc
PoolId:            	ff8080812be40338012be40474c000cd
PoolId:            	ff8080812be40338012be40474e200cf
[root@jsefler-rhel6-client01 pki]# subscription-manager-cli subscribe --pool=ff8080812be40338012be40473fb00cb
[root@jsefler-rhel6-client01 pki]# yum repolist all
Loaded plugins: refresh-packagekit, rhnplugin, rhsmplugin
Updating Red Hat repositories.
ERROR:certlib:File: /etc/pki/entitlement/key.pem, not loaded
140714675316480:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:698:Expecting: CERTIFICATE

INFO:repolib:repos updated: 3
ERROR:certlib:File: /etc/pki/entitlement/key.pem, not loaded
140714675316480:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:698:Expecting: CERTIFICATE

Options Error: Error parsing "gpgkey = 'http/foo/path/never/gpg'": URL must be http, ftp, file or https not ""



^ DID NOT EXPECT THOSE ERRORS
I HAVE NOTICED THAT key.pem IS NEWLY BEING DROPPED INTO /etc/pki/entitlement
NOT SURE WHY.  LOOKS LIKE yum DOES NOT LIKE IT.

Comment 1 James Bowes 2010-11-01 19:54:28 UTC
I've set it up to ignore key.pem now.

Comment 3 John Sefler 2010-12-07 18:56:38 UTC
VERSION
[root@jsefler-onprem01 ~]# rpm -q subscription-manager
subscription-manager-0.93.2-1.git.82.b7841b3.fc14.x86_64
[root@jsefler-f12-candlepin candlepin]# git show-ref master
5773be9a35b8697e7e53b3ae23fbb38ba881f0e1 refs/heads/master
5773be9a35b8697e7e53b3ae23fbb38ba881f0e1 refs/remotes/origin/master


[root@jsefler-onprem01 ~]# subscription-manager register --username=testuser1 --password=password
55a1a27c-5640-4149-83df-b886fea6276e testuser1
[root@jsefler-onprem01 ~]# yum repolist all
Loaded plugins: product-id, refresh-packagekit, rhnplugin, subscription-manager
Updating Red Hat repositories.
INFO:repolib:repos updated: 3
repo id                                       repo name                                                                          status
rhel-x86_64-server-6                          Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)                           enabled: 3,589
repolist: 3,589
[root@jsefler-onprem01 ~]# subscription-manager list --available | grep PoolId
PoolId:            	ff8080812cc18643012cc1871f2701ed
[root@jsefler-onprem01 ~]# subscription-manager subscribe --pool=ff8080812cc18643012cc1871f2701ed
[root@jsefler-onprem01 ~]# yum repolist all
Loaded plugins: product-id, refresh-packagekit, rhnplugin, subscription-manager
Updating Red Hat repositories.
INFO:repolib:repos updated: 3
https://mockamai.devlab.phx1.redhat.com/foo/path/always/repodata/repomd.xml: [Errno 14] problem making ssl connection
Trying other mirror.
repo id                                          repo name                                                                           status
always-enabled-content                           always-enabled-content                                                              enabled: 0
content-label                                    content                                                                             enabled: 0
never-enabled-content                            never-enabled-content                                                               disabled
rhel-x86_64-server-6                             Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)                            enabled: 0
repolist: 0
[root@jsefler-onprem01 ~]# ls /etc/pki/entitlement/
1129174797755692.pem  key.pem




VERIFIED NO MORE ERROR:certlib:File: /etc/pki/entitlement/key.pem, not loaded
despite the presence of /etc/pki/entitlement/key.pem

moving to VERIFIED

Comment 4 errata-xmlrpc 2011-05-19 13:42:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.