Bug 646569 - Cascade Delete results in "Got error -1 from storage engine"
Summary: Cascade Delete results in "Got error -1 from storage engine"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql
Version: 13
Hardware: Unspecified
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 648622 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-25 17:39 UTC by Red Ochsenbein
Modified: 2013-07-03 03:33 UTC (History)
3 users (show)

Fixed In Version: mysql-5.1.52-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 21:47:23 UTC
Type: ---


Attachments (Terms of Use)

Description Red Ochsenbein 2010-10-25 17:39:53 UTC
Description of problem:
MySQL is reporting:
  ERROR 1030 (HY000): Got error -1 from storage engine

The error log is reporting:
  InnoDB: Cannot delete/update rows with cascading foreign key constraints that exceed
max depth of 250

Version-Release number of selected component (if applicable):
$ rpmquery mysql-server
mysql-server-5.1.51-2.fc13.i686


Additional info:
There is a bug filed for this in the MySQL Bugtracker.

http://bugs.mysql.com/bug.php?id=57255

Comment 1 Tom Lane 2010-11-01 20:21:04 UTC
*** Bug 648622 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2010-11-02 03:45:11 UTC
mysql-5.1.52-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mysql-5.1.52-1.fc14

Comment 3 Fedora Update System 2010-11-02 03:45:22 UTC
mysql-5.1.52-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mysql-5.1.52-1.fc13

Comment 4 Fedora Update System 2010-11-02 22:12:57 UTC
mysql-5.1.52-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mysql-5.1.52-1.fc13

Comment 5 Fedora Update System 2010-11-10 21:47:16 UTC
mysql-5.1.52-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2010-11-10 21:47:49 UTC
mysql-5.1.52-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.