Bug 646625 - KMess crash when receiving offline IM
Summary: KMess crash when receiving offline IM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kmess
Version: 14
Hardware: All
OS: Unspecified
low
urgent
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-25 19:03 UTC by Mathieu F
Modified: 2010-11-24 22:45 UTC (History)
2 users (show)

Fixed In Version: kmess-2.0.5-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-24 22:43:06 UTC
Type: ---


Attachments (Terms of Use)

Description Mathieu F 2010-10-25 19:03:11 UTC
Description of problem:
KMess crash due to incorrect parsing of offline IM data.

Version-Release number of selected component (if applicable):
kmess-2.0.4-1.fc14 and kmess-2.0.3-1.fc14
Lower version as well (including F13 and others).

How reproducible:
Very High

Steps to Reproduce:
1. Connect to IM account.
2. Receive offline IM.
  
Actual results:
KMess crash.

Expected results:
KMess shows offline IM.

Additional info:
Bug is discussed here : http://kmess.org/board/viewtopic.php?f=4&t=4685
Fix is here : http://gitorious.org/kmess/kmess/commit/436e62d23743664c7b0ab7395fe269a000d0829d

It would be nice to have a fast backport. Thanks in advance !

Comment 1 Mathieu F 2010-10-25 20:05:09 UTC
I've just compile git stable branch. Works wonderful.

Comment 2 Mathieu F 2010-10-26 08:24:10 UTC
KMess 2.0.5 is just released. Please update it.
"fixed a crash due to changes by Microsoft in how Offline Messages are sent."

Comment 3 Fedora Update System 2010-10-31 20:02:26 UTC
kmess-2.0.5-2.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/kmess-2.0.5-2.fc12

Comment 4 Fedora Update System 2010-10-31 20:03:03 UTC
kmess-2.0.5-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kmess-2.0.5-2.fc13

Comment 5 Fedora Update System 2010-10-31 20:03:38 UTC
kmess-2.0.5-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kmess-2.0.5-2.fc14

Comment 6 Fedora Update System 2010-11-01 20:49:47 UTC
kmess-2.0.5-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kmess'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kmess-2.0.5-2.fc12

Comment 7 Fedora Update System 2010-11-24 22:43:01 UTC
kmess-2.0.5-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-11-24 22:45:34 UTC
kmess-2.0.5-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-11-24 22:45:44 UTC
kmess-2.0.5-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.