Bug 64664 - KDE font installer uses "xfs restart", crashes X
KDE font installer uses "xfs restart", crashes X
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
limbo
All Linux
high Severity high
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-05-09 06:47 EDT by Warren Togami
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 06:07:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quick-n-dirty (ie, untested) patch to replace xfs restart with xfs reload. (1.25 KB, patch)
2002-06-14 09:44 EDT, Rex Dieter
no flags Details | Diff
attempt #2 (2.91 KB, patch)
2002-06-14 11:49 EDT, Rex Dieter
no flags Details | Diff
KDE font installer screenshot (deleted)
2002-07-31 05:58 EDT, Ngo Than
no flags Details
KDE font installer screenshot (deleted)
2002-07-31 05:58 EDT, Ngo Than
no flags Details

  None (edit)
Description Warren Togami 2002-05-09 06:47:25 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux) 
 
Description of problem: 
Within the KDE Control Center > System > Font Installer > Settings Tab > X 
System it has settings to refresh X's font list after it has installed new 
fonts. 
 
The default setting is "/etc/rc.d/init.d/xfs restart" 
 
I am quite sure that doing this will ALWAYS freeze X because it loses its 
current connection to xfs.  At least that's the behavior that I experience on 
my LTSP and local installations. 
 
A setting of "/etc/rc.d/init.d/xfs reload" would have the desired effect, 
without crashing the current X session. 
 
Version-Release number of selected component (if applicable): 
Red Hat 7.3 (Valhalla) fresh install 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Install fonts with KDE Font Installer. 
2. Apply and allow it to restart xfs with its default settings. 
  
Actual Results:   
X freezes up after it lost its connection to the original xfs daemon. 
 
Expected Results:   
X shouldn't freeze up.
Comment 1 Mike A. Harris 2002-05-28 10:35:21 EDT
Correct.  "service xfs restart" should never under any circumstance be
executed while the X server is running.  "service xfs reload" should
be used instead.

This did actually work a while back, because the xfs initscript incorrectly
made restart work like reload.
Comment 2 Mike A. Harris 2002-05-28 10:38:36 EDT
We might want to suggest rpmlint get a new test for this for rpm
scripts to ensure xfs initscript isn't called with restart except on
xfs upgrade.
Comment 3 Rex Dieter 2002-06-14 09:44:12 EDT
Created attachment 60966 [details]
quick-n-dirty (ie, untested) patch to replace xfs restart with xfs reload.
Comment 4 Rex Dieter 2002-06-14 11:49:15 EDT
Created attachment 60988 [details]
attempt #2
Comment 5 Warren Togami 2002-07-12 09:57:16 EDT
Still appears to be broken in Limbo.  I haven't tested it, but it still says
"restart" in the KDE font installer config.
Comment 6 Mike A. Harris 2002-07-13 04:33:42 EDT
This bug is a high priority since not fixing it will likely cause odd
bug reports coming in of X crashing for a seemingly unknown reason, which
would waste a lot of troubleshooting time.

The above patch above should do it.  Please apply.
Comment 7 Ngo Than 2002-07-15 05:56:15 EDT
It's now fixed in kdebase-3.0.2-3.
Comment 8 Jay Turner 2002-07-29 21:22:32 EDT
None of the changes above have been applied to kdebase-3.0.2-6.  Still calling
xfs restart in all cases.
Comment 9 Mike A. Harris 2002-07-29 22:30:24 EDT
This is ABSOLUTELY critical to get fixed.  Calling restart will kill
the X server 100% of the time, and must NOT be done.

I may remove the "restart" entry from the initscript entirely just
to make sure that it does not get called, since it will fry the X
server.

The only reason it is there, is to allow restarting the xfs server
when X is *not* running, using FHS/LSB initscript semantics.
Comment 10 Havoc Pennington 2002-07-30 09:56:36 EDT
The font installer is pretty pointless anyway since all Qt3 and GTK 2 apps won't
see the fonts, right? Or are they installed somewhere that fonts.conf lists?
Comment 11 Ngo Than 2002-07-31 06:07:39 EDT
Jay, are you sure that you have started KDE font installer in
kcontrol->System->Font installer?

The kdebase-3.0.2-3 or newer already included this fix. It uses "xfs reload"
instead "xfs restart". I have tested it and it works for me after i
added/removed some fonts with KDE font installer.

Could you please check again? thanks

Havoc: you can give font path to KDE font installer. Default are
/usr/share/fonts and /usr/X11R6/lib/X11/fonts. Of course all X
applications/Qt3/Gnome 2 will see these fonts, because the settings will be
saved in /etc/X11/fs/config


Note You need to log in before you can comment on or make changes to this bug.