Bug 64668 - permissions on /usr/lib/kde2-compat set incorrectly
permissions on /usr/lib/kde2-compat set incorrectly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kde2-compat (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: wdovlrrw
Mike McLean
:
Depends On:
Blocks: 65990 67217
  Show dependency treegraph
 
Reported: 2002-05-09 07:10 EDT by Matthew Booth
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-12 18:13:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2002-05-09 07:10:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
I installed 7.3 by upgrading from 7.2. On trying to use a kde application
(something I don't think I've ever done before) I noticed 'cannot load shared
library'. Some investigation turned up a lack of global +x permissions on
/usr/lib/kde2-compat and all its subdirectories.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install 7.2
2. Upgrade to 7.3

The upgrade thing may or may not be relevant. I haven't tried.
	

Additional info:

I have the Ximian GNOME packages installed, but I'm pretty sure they don't touch
KDE.
Comment 1 Kirk 2002-05-17 22:50:45 EDT
I have the same problem, and I came to the same conclusion...trying to run a
kde2 application, I get:

error while loading shared libraries: libkfile.so.3: cannot open shared object
file: Permission denied

I also upgraded from 7.2, but I have not done anything with ximian.  I don't get
this error running the program as root.

Comment 2 Adam Pribyl 2002-05-21 04:17:41 EDT
It is not necessary to install rh72 and upgrade to rh73 to reporoduce this bug.
You can easily look into package kde2-compat-2.2.2-2 where are permitions for
./kde2-compat/ subdirs bin, lib and share set to 644.

These permitions should be 755 ("chmod 755 .*" in folder /usr/lib/kde2-compat).

Comment 3 Neil Prockter 2002-06-01 04:59:35 EDT
a proper fix is 
 
find /usr/lib/kde2-compat -type d -exec chmod a+x {} \; 
 
files don't want to be executable. the files in 
/usr/lib/kde2-compat/bin are correctly executable already
Comment 4 Bill Nottingham 2002-07-12 15:48:20 EDT
*** Bug 65990 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.