Bug 64673 - GlibC 2.2.5 causes errors on somes program's
GlibC 2.2.5 causes errors on somes program's
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 08:39 EDT by Unmanarc
Modified: 2016-11-24 10:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 14:20:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Unmanarc 2002-05-09 08:39:56 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux) 
 
Description of problem: 
When I try to install imici 1.0 and ethercap, both programs causes an error 
not founding glibc libraries. but we have glibc 2.2.5. 
 
other problem is on vmware that does not working with rh73- 
 
 
 
Version-Release number of selected component (if applicable): 2.2.5 
 
 
How reproducible: 
Sometimes 
 
Steps to Reproduce: 
1.Install imici 
2.Install vmware 3 
3.Install ethercap 
  
 
Actual Results:  program results: 
vmware: 
VMware PANIC: (ide0:0) NOT_IMPLEMENTED F(831):688 
VMware PANIC: (VMX) AIO: NOT_IMPLEMENTED F(831):688 
 
imici: 
imici: relocation error: imici: symbol __on_exit, version GLIBC_2.0 not 
defined in file libc.so.6 with link time reference 
 
 
 
Additional info: 
any solutions?
Comment 1 Nathan G. Grennan 2002-05-09 19:17:38 EDT
You should be able to fix the VMware problem by upgrading VMware.
Comment 2 Jakub Jelinek 2002-05-10 08:43:01 EDT
The vmware problem is bug in vmware, they incorrectly assume nice(3) will
return non-zero on error (while SuS and other standards require it to return
actual priority, error is signalled by returning -1 and setting errno).
AFAIK VMWare knows about this bug and have fixed it already.

Concerning imici, it is not supposed to use __on_exit which is a glibc private
interface (always has been). It has to use on_exit instead. Ask imici to fix
it.
You have not listed any errors for ethercap, so I cannot say anything about it.
Comment 3 Unmanarc 2002-05-10 12:04:39 EDT
ok, VMWARE 3.1 and ETTERCAP 0.6.5 is now working

thx!
Comment 4 Mikko Tiihonen 2002-05-13 14:19:53 EDT
Could the nice problem be solved with the glibc symbol versioning?

Wasn't the versioning introduced just to support the this kind of
situtations where the interface must be changed but old binaries require the old
interface to function. Does the versioning slow down programs or is there any
other reason not to use it?

To get vmware 2.x series running I had to create my own preloaded library that
wraps the nice function and always returns 0. Unfortunately the vmware is a suid
program and thus the wrapper library needs to be in /usr/lib and the whole
program must be run as root to make it work.
Comment 5 Jakub Jelinek 2002-05-14 08:18:10 EDT
This was a bug in nice(2) implementation (it did not work as documented)
and for bugfixes glibc doesn't come up with new symbol version.

Note You need to log in before you can comment on or make changes to this bug.