Bug 64676 - accessing LS120 disk drive can hang system
accessing LS120 disk drive can hang system
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 10:21 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 14:12:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-09 10:21:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When accessing the LS120 drive the system either hangs when reading the disk or 
when umnounting it. This worked fine under RH7.1 IA64, but not under RH7.2. The 
kernel has been updated to 2.4.9-31 and all package updates have been applied. 
As a side note, if I managed to read the disk at all the directory list look ok 
but any file contents are garbage. No entries in the system log files have ever 
been added due to this, although once a SEGV was flashed on the screen prior to 
the system hanging.

Red Hat service request 205284 was also raised against this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mount /dev/hda on /mnt/ls120
2.ls -l /mnt/ls120
3.read a file from /mnt/ls120
4.umount /mnt/ls120
	

Actual Results:  the system will either hang at step 3 or 4.

Expected Results:  shouldn't hang

Additional info:
Comment 1 Need Real Name 2002-05-29 09:11:10 EDT
This would seem to be related to bug#60709. If we turn of dma with 'hdparm -
d0 /dev/hda' then not only does it not hang but we can actually read real data 
drom files on the disk rather than garbage. Unlike 60709 we only have 4GB of 
ram.

Comment 2 Alan Cox 2003-06-09 14:12:44 EDT
For drives that behave this should be resolved in the 2.4.20 errata. If not
please give me the info on the drive and I'll blacklist it properly. Old kernels
kept the LS120 in PIO always ...


Note You need to log in before you can comment on or make changes to this bug.