Bug 64677 - can't install on base Red Hat system due to unnecessary Perl usage
can't install on base Red Hat system due to unnecessary Perl usage
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: postfix (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 10:22 EDT by Chris Ricker
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-09 11:44:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-05-09 10:22:52 EDT
Postfix is not installable on a base Red Hat install, because the postfix spec
includes this little gem that needs to be rewritten using sed:

# Put db3 in the chroot jail, but only if the soname is correct
%triggerin -- db3
%{copy_cmd}
DBVER=`ldd %{_libexecdir}/postfix/pickup |grep libdb |perl -pi -e "s,\s+,,g;s,=>
.*,,"`
if [ -e "/lib/$DBVER" ]; then
        copy "/lib/$DBVER" %{ROOT}/lib
fi


Perl cannot be used in specs!  It may or may not be installed....  When
installing postfix on systems which don't have or need perl, the install fails
in the %post phase because of this.
Comment 1 Michael Schwendt 2002-05-09 11:44:53 EDT
Encountered this today on a machine where I've protected perl. With sed, one fix
would be:

DBVER=`ldd /usr/libexec/postfix/pickup |grep libdb |sed s,[[:blank:]],,g;s,=>.*,,"`

Note You need to log in before you can comment on or make changes to this bug.