Bug 646775 - Misleading number of enterprise_entitled required when rhn-satellite-activate
Misleading number of enterprise_entitled required when rhn-satellite-activate
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
540
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2010-10-26 03:50 EDT by Šimon Lukašík
Modified: 2012-03-08 04:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-23 08:33:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Šimon Lukašík 2010-10-26 03:50:32 EDT
Description of problem:
Activation of satellite with huge db fail when using insufficient
certificate.  But the error listed looks suspicious.

Version-Release number of selected component (if applicable):
Sat530+, Sat540

How reproducible:
deterministic

Steps to Reproduce:
1. Have a large database
2. rhn-satellite-activate with 'lite' cert.
3.
  
Actual results:
Error: You do not have enough unused enterprise_entitled entitlements
in the base org. You will need at least 394374 free entitlements,
based on your current consumption. Please un-entitle the remaining
systems for the activation to proceed.

Expected results:
I have about 26000 system registered, therefore I would expect that I need
26000 management entitlements.


Additional info:
Comment 4 Jan Pazdziora 2011-12-05 06:00:00 EST
The problem was introduced by

  commit 480b60089dc138840d769f07563622a77ce5f71c
  Author: Pradeep Kilambi <pkilambi@redhat.com>
  Date:   Wed May 27 17:04:03 2009 -0400

which was presumably a fix for bug 498517 (fixing the error message to show the needed free entitlements for the activation to proceed). However, the arithmetics does not take used entitlements into account, it merely uses all existing entitlements and substracts the new entitlement value.

Note You need to log in before you can comment on or make changes to this bug.