Bug 64688 - MiniChinput's input interface is garbled. This only happens in 7.3.
MiniChinput's input interface is garbled. This only happens in 7.3.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: miniChinput (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
David Lawrence
http://www.eyz.ca/gallery/miniChinput...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 14:06 EDT by Eric Yuan Zhao
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-10 03:14:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the bug (209.76 KB, image/png)
2002-05-10 02:02 EDT, Eric Yuan Zhao
no flags Details

  None (edit)
Description Eric Yuan Zhao 2002-05-09 14:06:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
When miniChinput's input window is triggered, its contents are not printed properly.  Part of them are cut off and the rest are stacked over each other.  This makes it totally unreadable. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Simplified Chinese support (fonts and miniChinput)
2. Set locale to zh_CN
3. Start X
4. Press <ctrl>+<space> to trigger miniChinput's input interface
 

Actual Results:  The contents on the input window are not readable.  They are partially cut off and stacked over each other.

Expected Results:  The contents should be printed in a readable manner.

Additional info:

I've tried miniChinput on 2 completely different computers both with RH 7.3 installed and got the same result.  I replaced the package with the one shipped in 7.2, and then it worked.
Comment 1 Yu Shao 2002-05-09 19:23:14 EDT
I didn't find this problem, but giving us a screenshot and telling me the
version numbers of miniChinput, ttfonts-zh_CN, XFree86 would help.

# rpm -q ttfonts-zh_CN
# rpm -q miniChinput
# rpm -q XFree86
Comment 2 Eric Yuan Zhao 2002-05-10 02:02:58 EDT
Created attachment 56904 [details]
screenshot of the bug
Comment 3 Eric Yuan Zhao 2002-05-10 02:04:41 EDT
Versions: 
 
 ttfongs-zh_CN: 2.11-21 
miniChinput: 0.0.3-18 
XFree86: 4.2.0-8 
Comment 4 Yu Shao 2002-05-10 02:48:08 EDT
On my machine it is perfectly ok, I couldn't reproduce your problem.
Comment 5 Yu Shao 2002-05-10 02:58:24 EDT
Do you have the same problem in GNOME?
Comment 6 Yu Shao 2002-05-10 03:14:25 EDT
You should set your locale as zh_CN.GB2312, zh_CN.GBK, or zh_CN.GB18030. 

zh_CN is actually zh_CN.GB2312, next miniChinput update will be able to handle
locale "zh_CN" correctly. Thank you for your report.

Note You need to log in before you can comment on or make changes to this bug.