Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 646892

Summary: Future provisioning will fail due to timeout calculated off current time not scheduled time
Product: Red Hat Satellite 5 Reporter: Justin Sherrill <jsherril>
Component: ProvisioningAssignee: Stephen Herr <sherr>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Korbel <mkorbel>
Severity: medium Docs Contact:
Priority: low    
Version: 540CC: cperry, jpazdziora, mkorbel, sandro, tlestach, tpapaioa
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: spacewalk-java-1.2.74-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-21 09:34:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 819081    

Description Justin Sherrill 2010-10-26 15:10:26 UTC
Description of problem:

When scheduling a provisioning of a system the expiration time of the tiny URL is 4 hours + CURRENT_TIME whereas it should be 4 hours + scheduled time.


Steps to Reproduce:
1.  Schedule a kickstart to occur 24 hours later
2.  Wait 24 hours

  
Actual results:
It works

Expected results:
It fails.


Should affect Sat 5.3 and 5.4

Comment 1 Justin Sherrill 2010-10-26 15:23:24 UTC
fixed in spacewalk master:

becad020047d0dae2c68381b998e306077129091

Comment 2 Sandro Mathys 2010-10-27 12:59:06 UTC
(In reply to comment #0)
> 
> Actual results:
> It works
> 
> Expected results:
> It fails.

Justin, you sure about that? :)

Thanks for the quick fix!

Comment 3 Tomas Lestach 2011-06-17 14:14:03 UTC
Moving to MODIFIED, since Justin fixed it.

Comment 4 Tomas Lestach 2011-06-17 14:16:14 UTC
*** Bug 708520 has been marked as a duplicate of this bug. ***

Comment 7 Clifford Perry 2012-09-21 09:34:57 UTC
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite

Comment 8 Martin Korbel 2012-10-30 16:31:25 UTC
*** Bug 517252 has been marked as a duplicate of this bug. ***