Bug 64698 - forced fsc w/ ext3 partitions
forced fsc w/ ext3 partitions
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 15:53 EDT by Mike Wangsmo
Modified: 2014-03-16 22:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Wangsmo 2002-05-09 15:53:25 EDT
Description of Problem:

when the root partition is uncleanly unmounted (hard system reset), the
rc.sysinit script somehow forces a fsck on the partition instead of allowing for
journal reconstruction.  

Version-Release number of selected component (if applicable):


How Reproducible:

Every time.

Steps to Reproduce:
1. reset running system with "/" as ext3
2. upon bootup, the message "Press Y within X seconds to force ...", do nothing
3. 

Actual Results:

theorectically, the system should skip the fsck and mount the ext3 partition,
allowing the ext3 journaling code to reconstruct the journal.  This doesn't happen.

Expected Results:


Additional Information:
	
This bug is corrected in the 7.3 initscripts.  I even tried forcing the
AUTOFSCK_OPT option to NULL, still ended up getting a fsck'y.  Anyway, I've
upgraded my laptop to 7.3 and the expected behavior is present.  I tried diffing
the .rpmsave version which I would assume is the one that was here before the
upgade (although I won't swear to that).  They are exactly the same. <shrug>
Comment 1 Bill Nottingham 2002-06-12 03:11:15 EDT
Odd. Did your 7.2 initrd have ext3 in it?
Comment 2 Mike Wangsmo 2002-06-12 11:06:36 EDT
I don't recall.  I did an upgrade from 6.2 to 7.2 and selected ext3 for my "/"
partition when the installer promted me to convert to ext3.  My filesystem was /
== ext3 and /boot == ext2 on the 7.2 system.  I do not know what was contained
in my initrd for the 7.2 system, it would have been what ever was installed by
the 7.2 upgrade process.

I don't recall if I upgraded my kernel rpm or not.  If I did upgrade it, then I
didn't build a new initrd.  Assuming I did upgrade my kernel rpm and didn't
build a new initrd, would that have been able to cause this?  The ext3
filesystem was operating as ext3 according to my boot logs, I remember watching
that stuff.
Comment 3 Pancrazio `ezio' de Mauro 2004-05-18 11:52:42 EDT
*** Bug 105617 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2005-09-29 15:55:19 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.