This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 647091 - VNC authentication only check first 8 characters
VNC authentication only check first 8 characters
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-10-27 03:23 EDT by YangFeng
Modified: 2015-04-19 20:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-14 07:17:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description YangFeng 2010-10-27 03:23:11 EDT
Description of problem:
When setting VNC password longer than 8 characters, VNC authentication only check first 8 characters when connection.

Version-Release number of selected component (if applicable):
kernel: 2.6.18-227.el5
kvm version: kvm-83-206.el5

How reproducible:
100%

Steps to Reproduce:
1. Start guest with -vnc :port,password.
2. Go to qemu-monitor, input "change vnc password".
3. Set your password to '1234567890'.
4. Use vnc client to connect the guest.
5. Input '12345678' as password in vnc client.


Actual results:
vnc client connect to guest successfully.

Expected results:
vnc client could not connect to guest.  'Authentication failed' is displayed.

Additional info:

Input '1234567' (first 7 characters) as password in vnc client, then 'Authentication failed' is displayed.

qemu command line:
qemu-kvm -name 'vm1' -monitor /dev/tty -serial unix:'/tmp/serial-20101025-181459-zb56',server,nowait -drive file='/usr/autotest/client/tests/kvm/images/RHEL-Server-5.5-64-virtio.qcow2',index=0,if=virtio,media=disk,cache=none,boot=on,format=qcow2 -net nic,vlan=0,model=rtl8139,macaddr='02:8F:A8:D8:2c:85' -net tap,vlan=0,ifname='rtl8139_0_8000',script='/usr/autotest/client/tests/kvm/scripts/qemu-ifup-switch',downscript='no' -m 2048 -smp 2 -cpu qemu64 -soundhw ac97 -vnc :0,password -rtc-td-hack -M rhel5.5.0 -usbdevice tablet -no-kvm-pit-reinjection
Comment 5 RHEL Product and Program Management 2011-01-11 15:28:56 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 17:55:00 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.