Bug 647095 - jabberd-2.2.11-1.el5 removes /etc/jabberd/server.pem
Summary: jabberd-2.2.11-1.el5 removes /etc/jabberd/server.pem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: jabberd
Version: el5
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-27 08:01 UTC by Till Maas
Modified: 2010-11-27 18:57 UTC (History)
3 users (show)

Fixed In Version: jabberd-2.2.11-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-19 22:30:51 UTC
Type: ---


Attachments (Terms of Use)

Description Till Maas 2010-10-27 08:01:13 UTC
Description of problem:
jabberd-2.2.8-2.el5 has a %ghost entry for /etc/jabberd/server.pem, the new update has not. Therefore the certificate is removed with this update, making the server fail to start.

Version-Release number of selected component (if applicable):
jabberd-2.2.11-1.el5

How reproducible:
always

Steps to Reproduce:
1. configure the old jabber to use /etc/jabberd/server.pem
2. update

  
Actual results:
does not work anymore, /etc/jabberd/server.pem is removed

Expected results:
/etc/jabberd/server.pem should be kept.

Additional info:
This is mentioned in bodhi:
https://admin.fedoraproject.org/updates/jabberd-2.2.11-1.el5

Comment 1 Dominic Hopf 2010-10-28 19:25:42 UTC
Thanks very much for reporting this issue, Till. I have just fixed this locally here. I'll now have a look at #647100 and hope to get this also fixed this evening to push another update...

I'm just curious... I got the feeling this issue and #647100 is major enough to push that update directly to stable. How do you think about this?

Comment 2 Till Maas 2010-10-28 19:40:43 UTC
(In reply to comment #1)
> Thanks very much for reporting this issue, Till. I have just fixed this locally
> here. I'll now have a look at #647100 and hope to get this also fixed this
> evening to push another update...
> 
> I'm just curious... I got the feeling this issue and #647100 is major enough to
> push that update directly to stable. How do you think about this?

An update for this bug needs to be pushed asap, if you want to avoid people hitting this bug. But if people have already updated to the current update, there is no way of fixing this issue. Also I am not sure how you are going to fix this. Just %ghosting it again will only make it more likely to hit this bug again. Maybe using %config(noreplace) with an empty file makes more sense, because removing it might not cause any issues.

Comment 3 Dominic Hopf 2010-10-30 18:19:14 UTC
Just for completeness I also mention this here (I previously replied to #647100 already):

http://dmaphy.fedorapeople.org/jabberd2/jabberd-2.2.11-2.fc14.src.rpm should fix this issue.

Comment 4 Fedora Update System 2010-11-09 22:12:43 UTC
jabberd-2.2.11-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/jabberd-2.2.11-3.fc13

Comment 5 Fedora Update System 2010-11-09 22:12:54 UTC
jabberd-2.2.11-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/jabberd-2.2.11-3.fc14

Comment 6 Fedora Update System 2010-11-09 22:13:05 UTC
jabberd-2.2.11-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/jabberd-2.2.11-2.el5

Comment 7 Dominic Hopf 2010-11-09 22:16:05 UTC
There was no feedback from your site until today, thus I pushed the updates now as they are a bit important. Thanks very much again for reporting the issues. Feel free to give Karma on the updates depending on your test results if your going to review them. :)

Comment 8 Fedora Update System 2010-11-10 17:02:28 UTC
jabberd-2.2.11-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jabberd'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/jabberd-2.2.11-2.el5

Comment 9 Fedora Update System 2010-11-19 22:30:42 UTC
jabberd-2.2.11-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-11-19 22:31:40 UTC
jabberd-2.2.11-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-11-27 18:57:41 UTC
jabberd-2.2.11-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.