Bug 647108 - guest cannot resume from S3
guest cannot resume from S3
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: qspice (Show other bugs)
5.6
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
: Triaged
Depends On:
Blocks: Rhel5KvmTier2 657202
  Show dependency treegraph
 
Reported: 2010-10-27 04:48 EDT by Chao Yang
Modified: 2011-11-02 12:48 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 657202 (view as bug list)
Environment:
Last Closed: 2011-11-02 12:48:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
when resume from S3 (23.07 KB, image/png)
2010-10-28 04:26 EDT, Chao Yang
no flags Details

  None (edit)
Description Chao Yang 2010-10-27 04:48:53 EDT
Description of problem:


Version-Release number of selected component (if applicable):

--Host

#rpm -qa | grep kvm
etherboot-zroms-kvm-5.4.4-13.el5
kvm-qemu-img-83-204.el5
kmod-kvm-83-204.el5
kvm-tools-83-204.el5
kvm-83-205.el5
etherboot-roms-kvm-5.4.4-13.el5
kvm-debuginfo-83-204.el5

#uname -r
2.6.18-227.el5

#rpm -qa | grep spic
qspice-0.3.0-56.el5
qspice-debuginfo-0.3.0-56.el5
qspice-libs-0.3.0-56.el5

-Guest
#uname -r
2.6.18-194.el5

How reproducible:


Steps to Reproduce:
1.boot guest with spice and qxl
#/usr/libexec/qemu-kvm -M rhel5.6.0 -m 2G -smp 2 -drive file=/root/chayang/testcasefor5u6.raw,if=ide,format=raw,boot=on,cache=none,werror=stop -net nic,vlan=0,macaddr=24:23:12:25:b1:5a,model=e1000 -net tap,vlan=0,script=/etc/qemu-ifup -boot c -monitor stdio -spice host=0,ic=on,port=5930,disable-ticketing -qxl 1

2.connect to guest via spice client
# spice -h 10.66.91.43 -p 5930
3.Do s3 in guest
echo mem > /sys/power/state
  
Actual results:
guest can't resume successfully,details info please have a look at attchment 

Expected results:
guest resume successfully

Additional info:
Comment 1 Chao Yang 2010-10-27 04:56:57 EDT
Please note:
I also tested s3 using vnc,didn't hit this issue
Comment 2 Chao Yang 2010-10-28 04:26:15 EDT
Created attachment 456181 [details]
when resume from S3
Comment 4 RHEL Product and Program Management 2011-01-11 15:28:44 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 17:55:15 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 8 Andrew Cathrow 2011-11-02 12:48:31 EDT
We'll target this for RHEL6 only

Note You need to log in before you can comment on or make changes to this bug.