This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 647189 - migration of 8GB guest fails immediately
migration of 8GB guest fails immediately
Status: CLOSED DUPLICATE of bug 586643
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier1 639305
  Show dependency treegraph
 
Reported: 2010-10-27 10:04 EDT by Jiri Denemark
Modified: 2011-01-17 07:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-17 07:14:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Denemark 2010-10-27 10:04:59 EDT
Description of problem:

In fact, I was doing virsh managedsave but that uses qemu's migration capabilities so I'll talk about migration from now on...

Migrating 8GB guest after boot works just fine. Then I modify guest's memory, e.g., using the following code:

#include <stdlib.h>
#define size 7900000000L

int main(void)
{
        char *ble = malloc(size);
        long long i;

        if (!ble)
                return -1;

        for (i = 0; i < size; i++)
                ble[i] = i & 0xff;

        return 0;
}

After this process finishes, the guest can no longer be migrated. Actually the migration doesn't even start and the following error is printed immediately:

error: operation failed: migration to 'exec:cat | { dd bs=4096 seek=1 if=/dev/null && dd bs=1048576; } 1<>/var/lib/libvirt/qemu/save//console.save' failed: migration failed

No message appears on qemu's stderr.

Version-Release number of selected component (if applicable):

kvm-83-205.el5
kernel-2.6.18-228.el5

How reproducible:

Everytime.

Steps to Reproduce:
1. start a guest with 8GB of memory
2. modify guest's memory
3. virsh managedsave
  
Actual results:

migration failed


Expected results:

guest saved successfully

Additional info:

The guest is RHEL-5.5
Comment 1 Juan Quintela 2010-11-02 13:13:32 EDT
how much physical memory do you have on that machine?  just 8GB?

If so, that is the problem and this is a duplicate of: https://bugzilla.redhat.com/show_bug.cgi?id=586643
Comment 2 Jiri Denemark 2010-11-03 04:13:17 EDT
For the record of what I said on irc yesterday, the host has 10GB of memory.
Comment 6 RHEL Product and Program Management 2011-01-11 15:10:59 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 17:55:30 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 8 Juan Quintela 2011-01-17 07:14:56 EST

*** This bug has been marked as a duplicate of bug 586643 ***

Note You need to log in before you can comment on or make changes to this bug.