Bug 64719 - Kernel fails on checking partition table
Kernel fails on checking partition table
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i586 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 21:39 EDT by Edward Rudd
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Rudd 2002-05-09 21:39:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
System was running on RedHat 7.2 fine..
Installed RH7.3 but the installer failed to detect the partitions the second
"windows" harddrive.. I removed the second harddrive and the install mostly
proceeded fine.. (quit when it coulnd't install ttfonts-ko).. but once I put the
"windows" harddrive back in and booted the half upgraded linux install the
kernel stopped at the same point (checking partitions" on the "windows" harddrive..
The harddrive is a Maxtor 40GB harddrive..(this has windows on it) and the other
harddrive is a Maxtor 13GB (this has linux on it). the motherboard is a Asus
P5A-B w/ the 1010 bios (fix for HD > 32GB).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
install/bootup the 2.4.18 kernel from the install disk OR the installed system
with the 40GB Maxtor harddrive installed.

Actual Results:  kernel stops booting while checking the partitions on the 40GB..
output..
checking partitions (or whatever the wording is..)
 hda: 
and stops there

Expected Results:  to find a the partitions

Additional info:
Comment 1 Edward Rudd 2002-05-09 21:45:40 EDT
The 40GB Maxtor is model number 4D040H2
The 13GB Maxtor is model number 91303D6
Comment 2 Michael K. Johnson 2002-05-16 16:17:53 EDT
Does booting with "ide=nodma" help?
Comment 3 Edward Rudd 2002-05-20 19:21:04 EDT
well, that worked.. don't know why...
as I could have DMA mode on with RH 7.2..
and I need DMA support so that DVD playing will work...
I tried setting the USE_DMA=1 in the /etc/sysconfig/harddisks file and with the
ide=nodma option it boots through the kernel but stopps later in the boot
process when starting various services..
Comment 4 Bugzilla owner 2004-09-30 11:39:34 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.