Bug 64724 - Installer crashes on upgrade just before packages are installed
Summary: Installer crashes on upgrade just before packages are installed
Status: CLOSED DUPLICATE of bug 64592
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-10 03:26 UTC by Aaron VanDevender
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-10 18:03:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Dump File (76.24 KB, text/plain)
2002-05-10 03:29 UTC, Aaron VanDevender
no flags Details

Description Aaron VanDevender 2002-05-10 03:26:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
When performing an upgrade from a RedHat 7.2 system, the installer croakes and
spits out some python error message and allows you to dump to a floppy. This
happens between the dependancy check and the actual application of the packages.
The system then reboots and ends up in the same 7.2 state that it was in when
you started the upgrade.

I've attached the dump.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.begin upgrade from 7.2.
2.go through dependancy check.
	

Actual Results:  a stack trace and error box came up and asked to save to disk.

Expected Results:  It should have applied the packages and completed the upgrade.

Additional info:

Comment 1 Aaron VanDevender 2002-05-10 03:29:46 UTC
Created attachment 56884 [details]
Anaconda Dump File

Comment 2 Michael Fulbright 2002-05-10 15:47:32 UTC
Is /root a symlink on your system?

Comment 3 Aaron VanDevender 2002-05-10 18:03:43 UTC
Yes it is a symlink, and not only that but the link points to a directory on a
different partition, which is not getting mounted beneath /mnt/sysimage. 

I guess that would explain this message in the anaconda dump:

No such file or directory: '/mnt/sysimage/root/upgrade.log'

So this error would seem to be a problem how I have /root set up, and so doesn't
necessairily require a proper fix, but you would think that it could at least
fail more gracefully than dumping the whole upgrade. Maybe choose another
location for the log like /mnt/sysimage/upgrade.log or
/mnt/sysimage/var/log/upgrade.log, being more tenacious about mounting things
under /mnt/sysimage, or even just forgetting the log all together would be
better than abandoning the whole deal. 

A litttle robustness never hurt, right?

Comment 4 Michael Fulbright 2002-05-13 20:30:35 UTC
Correct - I've added '/root' to the list of directories that we check are not
links before proceeding.  It had not previously been in the list. Thanks for
catching our oversight.

*** This bug has been marked as a duplicate of 64592 ***


Note You need to log in before you can comment on or make changes to this bug.