Bug 647293 - parted crash (causing preupgrade to fail too)
parted crash (causing preupgrade to fail too)
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-27 15:56 EDT by Federico Pedemonte
Modified: 2011-06-14 19:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-14 19:31:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot.jpg (2.42 MB, image/jpeg)
2010-10-27 15:59 EDT, James Laska
no flags Details
output of the command 'fdisk -l' (1.45 KB, text/plain)
2010-10-27 16:18 EDT, Federico Pedemonte
no flags Details

  None (edit)
Description Federico Pedemonte 2010-10-27 15:56:46 EDT
Description of problem:

preupgrade -l ends with an abort

Version-Release number of selected component (if applicable):

preupgrade-1.1.8-1.fc13.noarch

How reproducible:

always

Steps to Reproduce:
1. preupgrade -l
  
Actual results:

Model: ATA SAMSUNG SV0602H (scsi)
Disk /dev/sda: 60.1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system     Flags
 1      32.3kB  1546MB  1546MB  primary  linux-swap(v1)
 2      1546MB  2180MB  633MB   primary  ext3            boot
 3      2180MB  60.1GB  57.9GB  primary  ext4


Backtrace has 14 calls on stack:
  14: /lib64/libparted-2.1.so.0(ped_assert+0x31) [0x35d2a11fb1]
  13: /lib64/libparted-2.1.so.0(ped_geometry_read+0x80) [0x35d2a19980]
  12: /lib64/libparted-2.1.so.0(hfsplus_probe+0x279) [0x35d2a30de9]
  11: /lib64/libparted-2.1.so.0(ped_file_system_probe_specific+0x5c) [0x35d2a1357c]
  10: /lib64/libparted-2.1.so.0(ped_file_system_probe+0xa5) [0x35d2a13b25]
  9: /lib64/libparted-2.1.so.0() [0x35d2a454ab]
  8: /lib64/libparted-2.1.so.0(ped_disk_new+0x75) [0x35d2a19115]
  7: parted() [0x40692c]
  6: parted() [0x4077cd]
  5: parted() [0x409764]
  4: parted() [0x40a95f]
  3: parted(main+0x2c) [0x40aa6c]
  2: /lib64/libc.so.6(__libc_start_main+0xfd) [0x35d1a1ec5d]
  1: parted() [0x404f49]
Aborted
Comment 1 James Laska 2010-10-27 15:59:31 EDT
Created attachment 456068 [details]
Screenshot.jpg

A similar, but more detailed backtrace was found when the reporter attempted to preupgrade this system to F-14.  See attached file for a screenshot.
Comment 2 James Laska 2010-10-27 16:13:01 EDT
I'm not sure if bcl will find it useful, but can you attach 'fdisk -l' output from this system as well?
Comment 3 Federico Pedemonte 2010-10-27 16:18:00 EDT
Created attachment 456071 [details]
output of the command 'fdisk -l'
Comment 4 Brian Lane 2010-10-27 16:59:28 EDT
Federico, was this traceback before the reboot into the installer or after, like jlaska's is?
Comment 5 Federico Pedemonte 2010-10-27 17:10:17 EDT
Brian, this is after I tried the installer, but issued in a "normal boot"
Comment 6 Brian Lane 2010-10-27 17:31:21 EDT
Did you mean parted -l not preupgrade -l?

Do you have HFS partitions in your system? What hardware is this?

Also, I think there should be an assert message along with the backtrace: Assertion (%s) at %s:%d in function %s() failed.
Comment 7 Federico Pedemonte 2010-10-29 01:01:11 EDT
after further investigation, I found out that it was my 2nd hard drive causing the issue.

So i removed it and parted worked nicely (and, by the way, the upgrade to f14 via preupgrade worked as expected).

Reinserting the disk, parted -l aborts again.

The disk gives me warning about being going to fail, but it has worked for years without an issue of any kind! (so I'm keeping not-so-important data on it)

By the way, i don't have any HFS partition on my system!
Comment 8 Brian Lane 2010-10-29 12:19:25 EDT
Its possible that the failing disk is reporting something unexpected. So, there is no associated Assertion line? That would tell us what parted thinks is wrong, although from the stack trace I suspect it is geometry related.
Comment 9 Federico Pedemonte 2010-10-29 12:47:59 EDT
Brian, unfortunately what I posted is all I get from parted: any Assertion line in there.
Comment 10 Bug Zapper 2011-05-30 10:43:15 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.