Bug 64730 - Notification Icon should indicate if reboot is required for all updates to take effect
Notification Icon should indicate if reboot is required for all updates to ta...
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 00:59 EDT by Neil Padgett
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-07 13:46:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Padgett 2002-05-10 00:59:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020417

Description of problem:
Currently, if a user downloads an updated kernel using up2date, after the kernel
is downloaded, the panel icon becomes a checkbox (to indicate system is
up-to-date will all current updates). This is misleading, since as noted in the
"Critical Information" tab, a reboot is required before the kernel update takes
effect.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do a fresh install of RHL 7.3.
2. Set-up RHN and RHN applet.
3. Observe that updates are required as indicated by the applet.
4. Apply all updates using up2date. Assume a kernel update is required and is
downloaded.
5. Note that the applet now indicates the system is up2date. No indication is
given via the panel icon that a reboot is required.

Expected Results:  The panel icon should have another state to indicate that the
system is up-to-date, but a restart is required before all updates will take
effect. A suitable panel icon should be displayed to indicate this state.

Additional info:
Comment 1 Daniel Veillard 2003-04-07 13:46:08 EDT
This is not indicated by the applet icon, but the information is
available from the dialog one gets when clicking on the icon
in the "Critical Information" panel for example
"Your system is currently running kernel-2.4.18-26.8.0, but the newest
 installed kernel is kernel-2.4.18-27.8.0. It is recommended that you 
 reboot at the first opportunity to test this new kernel."

Rebooting is not a trivial operation, and often can't be done immediately
after the update, especially in an enterprise environment. We should also
keep the icons and associated semantic relatively simple. It's a tradeoff
between keeping a simple interface and the relatively complex task of 
maintaining enterprise systems up to date.

I don't think in the current state we really want to really change the
current handling of this case.

Daniel

Note You need to log in before you can comment on or make changes to this bug.