This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 64740 - failed install leaves rpm database screwed
failed install leaves rpm database screwed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 07:54 EDT by Neal D. Becker
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-10 11:43:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal D. Becker 2002-05-10 07:54:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
I just tried to upgrade 7.2->7.2.  The process failed reading the 3rd cdrom. 
Problem is, the rpm  database was not updated.  I tried querying
rpm -q to check the versions of many packages, and they all still say older
versions, even though I can independently verify that many were updated.

Problem is, I don't see any way to recover from this.  Although anaconda is able
to do an update and resolve dependencies, I don't know any way for me to insert,
say, a good cdrom3 and get rpm to update the stuff I missed.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. update with a bad cdrom?
2.
3.
	

Additional info:
Comment 1 Jeremy Katz 2002-05-10 11:46:35 EDT
That's because we are working in a lookaside database in /var/lib/rpm.rebuilddb
-- if you move that to be /var/lib/rpm, instead, you get the new database.

Note You need to log in before you can comment on or make changes to this bug.