This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 64745 - countries not sorted using locale collation sequence in kaddressbook
countries not sorted using locale collation sequence in kaddressbook
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
http://bugs.kde.org/show_bug.cgi?id=4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 09:18 EDT by Miloslav Trmac
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-06 06:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2002-05-10 09:18:36 EDT
[reported also to bugs.kde.org]
Countries in the combo box (described below) are sorted using ASCII string 
comparison or something instead of locale-specified collation sequence.

Steps to Reproduce:
1.Set your locale to cs_CZ (or something other you can read which
places accented characters between unaccented Latin ones)
2.Run kaddressbook, create a new entry, push the Address button
3.Open the Country combo box. 

Actual Results:  The countries whose name starts with
an accented character (i.e. [using HTML notation because bugzilla will probably 
mangle it, etc.] Česká republika [Czech Republic]) are placed 
after all others.

Expected Results:  Česká republika is placed after countries 
whose name starts with C, but before countries with name starting with D, 
similarly for other countries.
Comment 1 Miloslav Trmac 2002-10-05 19:10:59 EDT
Same in 8.0
Comment 2 Miloslav Trmac 2003-01-10 06:34:19 EST
Same in phoebe.

Note You need to log in before you can comment on or make changes to this bug.