Bug 64749 - grub hangs at boot
grub hangs at boot
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 10:09 EDT by Daniel Hammer
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 14:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Hammer 2002-05-10 10:09:17 EDT
dhammer@noos.fr

Description of problem:
Grub Versions greater than grub-0.90-11 hang at boot before loading the
splash-screen. After printing out "Loading stage 1.5 (or 2) the whole
machine crashes

Version-Release number of selected component (if applicable):
every grub version greater than grub-0.90-11

How reproducible:
Always

Steps to Reproduce:

The machine is trying to boot from the master boot record of /dev/hda
Every is fine for all grub versions <= grub-0.90-11 even when
replacing the old splash-screen image by the new one.
Since the first version of "skipjack" booting with grub fails. I had
to boot from floppy and then replacing current version of grub by
grub-0.90-11

The relevant part of /boot/grub/grub.conf is as follows:

default=0
timeout=7
splashimage=(hd0,1)/grub/splash.xpm.gz
title Red Hat Linux (2.4.18-3)
	root (hd0,1)
	kernel /vmlinuz-2.4.18-3 ro root=/dev/hdb6 hdd=ide-scsi
	initrd /initrd-2.4.18-3.img
title winDoS (bitul zman)
	rootnoverify (hd0,0)
	chainloader +1
Comment 1 Jeremy Katz 2002-05-10 11:01:23 EDT
What type of motherboard is this?  Is your boot partition beyond the 1024th
cylinder, and if so, does your bios properly support lba32?
Comment 2 Daniel Hammer 2002-05-10 13:29:53 EDT
The machine is a "Fijitsu Siemens" with its own motherboard (e.g. it has no
extra specifiation other than F & S, probably it is assambled by them).

It is a Pentium 4 (140 MHz) motherboard and has a PhoenixBIOS version 4.06
Rev. 1.05.1194 from Phoenix Technologies Ltd and does (to my knowledge) 
properly support lba32.

The boot partition is /dev/hda2 which starts at cyl.383 and ends at cyl. 385   
 (24097+ blocks) and is thus not beyond the 1024th cylinder.

As I already said: all was fine (since Aug. 2001) befor "skipjack". 
The machine has a small windoze partition, an OpenBSD disk and also two other
Linux partition (Debian, SuSE, not indicated in the grub.conf above) which all
run fine on that machine.
Comment 3 Daniel Hammer 2002-07-07 19:04:13 EDT
Still no response; nothing has changed on this machine; i.e. the
problem is still the same (now for "limbo"). 
On another machine with an ASUS-board the long delay until showing 
the grub splash screen which occured on "skipjack" and 7.3 is now 
o.k. for "limbo".
Unfortunately the "Fijitsu Siemens" is the main machine and I still
have to boot via floppy or grub version =< 0.90-11
Comment 4 Mike McLean 2003-01-02 14:54:47 EST
This bug has been inappropriately marked MODIFIED. Please review the bug life
cycle information at 
http://bugzilla.redhat.com/bugzilla/bug_status.cgi

Changing bug status to ASSIGNED.
Comment 5 Jeremy Katz 2003-01-02 14:59:18 EST
Does this work better with grub 0.93 available from
http://people.redhat.com/~katzj/grub/?
Comment 6 Daniel Hammer 2003-01-02 15:25:37 EST
BS"D 
Jeremy, what happened, thought this discussion was already gone 'n over?
The grub package that I've downloaded from your site
http://people.redhat.com/~katzj/grub/
is perfect, and there is nothing left for me to worry about. Great work!
Comment 7 Jeremy Katz 2003-01-02 15:38:18 EST
I thought I remembered something, but somehow it dropped out of the database. 
I'll talk to our bugzilla guru, but glad to hear it's fixed.
Comment 8 Mike McLean 2003-01-21 14:06:03 EST
Closing based on reporter's comment.

Note You need to log in before you can comment on or make changes to this bug.