Bug 647495 - ypbind starts too late in the boot sequence (needs to be before netfs)
ypbind starts too late in the boot sequence (needs to be before netfs)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypbind (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Honza Horak
Tomas Dolezal
: Patch
Depends On:
Blocks: 782183 840699
  Show dependency treegraph
 
Reported: 2010-10-28 11:08 EDT by Shawn Stephens
Modified: 2015-05-28 19:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: After updating package, already existed symbolic links under /etc/rc.d are not updated and users are advised to run 'chkconfig ypbind resetpriorities' to apply new priorities defined in the updated package. Due to bug #887205 chkconfig doesn't updates only start priorities, which is sufficient in most cases. However, if we need to update kill priorities as well, we have to use 'chkconfig ypbind reset' and then 'chkconfig ypbind on' in case we want ypbind to start onboot. Result:
Story Points: ---
Clone Of: 169036
Environment:
Last Closed: 2013-02-21 05:33:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Stephens 2010-10-28 11:08:39 EDT
We still have this in the RHEL 6.0 Beta 2.

We are having to change the order since it wasn't fixed.  We like to mount our Oracle database NFS shares via /etc/fstab, and since ypbind isn't up before netfs, the filesystems fail to mount since they are trying to lookup the hostname.  I guess we could put in the FQDN for the hosts, but we resolv NIS hosts first.

It's probably good practice to have all of your nsswitch resolv capabilities running before starting netfs.


+++ This bug was initially created as a clone of Bug #169036 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Red Hat/1.7.10-1.4.2

Description of problem:
The rc*.d links to /etc/init.d/ypbind are out of sequence.

For hosts that mount NFS file systems that reside on a server which is only resolvable through NIS, ypbind must start before netfs. 

The symptom is that some NFS file systems were not mounting during boot but could be mounted with no problems with 'mount -a' after the system was fully booted.

The fix is to renumber the symlinks for ypbind in /etc/rc*.d to be before netfs. On a stock RHEL4 system, the links are S27ypbind which follows S25netfs in the boot process. If ypbind links are renamed S23ypbind, all NFS file systems mount correctly at boot time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /etc/fstab has an nfs mount whose server name is only resolvable by NIS
2. boot or reboot
3.
  

Actual Results:  NFS file system does not mount during boot.

Following boot, mount -a will correctly mount the file system.

Expected Results:  All NFS file systems should mount during boot.

Additional info:

To fix this on our systems, after a clean RHEL4 install, we run:

cp /etc/init.d/ypbind /etc/init.d/ypbind.orig
chkconfig --del ypbind
sed 's/# chkconfig: - 27 73/# chkconfig: - 23 77/' /etc/init.d/ypbind.orig \
  > /etc/init.d/ypbind
chkconfig --add ypbind
chkconfig --level 345 ypbind


Ideally, S23 or S23 (or anything appropriate and before netfs) should be the RHEL default start order for ypbind so we don't have to apply this workaround after each install.

--- Additional comment from cfeist@redhat.com on 2008-10-14 18:06:47 EDT ---

Is this still an issue?  It's very difficult to change service start ordering in the middle of a release.  We may need to move this to RHEL6.

--- Additional comment from cfeist@redhat.com on 2009-02-24 18:02:36 EST ---

Closing as there hasn't been any update in years.
Comment 2 Karel Klíč 2010-11-19 14:27:17 EST
S24 and K77 seem ok to me.
Comment 3 Karel Klíč 2010-11-19 14:30:26 EST
Correction: S24 and K76.
Comment 5 RHEL Product and Program Management 2011-01-07 10:32:26 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 RHEL Product and Program Management 2011-07-05 19:47:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 26 errata-xmlrpc 2013-02-21 05:33:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0426.html

Note You need to log in before you can comment on or make changes to this bug.