Bug 6475 - remote lpd got reset
remote lpd got reset
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.1
All Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-28 14:34 EDT by pau
Modified: 2014-03-16 22:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-04 15:56:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pau 1999-10-28 14:34:56 EDT
I and my colleague each is using a IBM thinkpad 770
running redhat 6.1 with a IBM pcmcia token ring interface.
We can do telent, ftp, web surffing without any problem.
But when we tried to lpr to a remote printer, nothing
got printed and the system reported no errors.

We used tcpdump to trace the packets between the thinkpad
and the printer server. The trace showed that after the
thnkpad closed the tcp connection by sending a FIN, the
remote lpd responded with 2 packets, one is a normal ACK
and the 2nd one is the same ACK but with PUSH (P) flag.
Then the thinkpad sent a reset. An strace on the thinkpad's
lpd did not show it reset (abort) the connection.

We are at a loss at this point. We do not know why a reset
is sent, and why everything else, including FTP download
from thw web worked so well.
Comment 1 Bill Nottingham 1999-10-28 16:31:59 EDT
Is there anything at all on the remote print server?
Are any errors recorded in /var/log/messages?
Comment 2 pizza 1999-11-04 10:04:59 EST
I am facing s similar problem that I believe is tied to the latest lpr
package released due to security issues.  I can't print to remote
spools (except useing samba).  No error messages on the server, but in
the client, I get "permission denied" messages when tryting to restart
the daemon.  It used to work... and yes, /etc/hosts.lpd is
up-to-date.  :)
Comment 3 Bill Nottingham 1999-11-04 11:46:59 EST
Which update version are you using?
Comment 4 pizza 1999-11-04 14:30:59 EST
lpr-0.44-1 on the rh 6.1 boxes.
lpr-0.44-0.5.2 on the rh 5.2 boxes which host the printers.

I'm going to snag the latest and greatest and see if it works.
Comment 5 pizza 1999-11-04 14:48:59 EST
I snagged the lpr-0.46 SRPM off of rawhide and that seems to have
solved the problems I was having.  Apparently it's the RH6.1 RPM
(lpr-0.44-1) that's broken.. and the RH5.2 one on the server was
working just fine.
Comment 6 Bill Nottingham 1999-11-04 15:56:59 EST
Yes, the 0.44 release has a few problems, that were fixed in
the 0.46 bugfix release.

(as for the other problem, that workaround is now in CVS, and
will be in the next lpr release.)

Note You need to log in before you can comment on or make changes to this bug.