Bug 647506 - boot hangs at udev
boot hangs at udev
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
14
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-28 11:29 EDT by sean
Modified: 2011-07-02 15:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: libmtp-1.0.6-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-02 15:26:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2010-10-28 11:29:50 EDT
Description of problem:

boot hangs at udev. Restarts on <Enter>

Version-Release number of selected component (if applicable):

kernel-2.6.35.6-45.fc14.x86_64
udev-161-4.fc14.x86_64

How reproducible:

reboot

Steps to Reproduce:
1.
2.
3.
  
Actual results:
[    4.922233] dracut: Switching root
[    5.936739] readahead: starting
[    6.972625] udev[470]: starting version 161
[   68.933964] type=1400 audit(1288226264.060:4): avc:  denied  { mmap_zero } for  pid=490 comm="vbetool" scontext=system_u:system_r:vbetool_t:s0-s0:c0.c1023 tcontext=system_u:system_r:vbetool_t:s0-s0:c0.c1023 tclass=memprotect
[   72.778450] microcode: CPU0: patch_level=0x10000bf

It only restarted when I hit enter

Expected results:


Additional info:

looks like selinux problem. This is a real problem on a server!
Comment 1 Harald Hoyer 2010-10-28 12:04:43 EDT
<enter> ???
udev does not read from the keyboard :)

try "udev.loglevel=info" on the kernel command line
Comment 2 sean 2010-10-31 10:13:40 EDT
Well forever was wrong. If I don't press a key, it's almost exactly 5 minutes:

[    4.447693] dracut: Switching root
[    5.162934] readahead: starting
[    6.473625] udev[463]: starting version 161
[  306.621264] Clocksource tsc unstable (delta = 300006081409 ns)
[  306.631726] Switching to clocksource hpet
[  309.016668] type=1400 audit(1288493951.141:4): avc:  denied  { mmap_zero } for  pid=483 comm="vbetool" scontext=system_u:system_r:vbetool_t:s0-s0:c0.c1023 tcontext=system_u:system_r:vbetool_t:s0-s0:c0.c1023 tclass=memprotect
[  309.308590] microcode: CPU0: patch_level=0x10000bf
[  309.620698] EDAC MC: Ver: 2.1.0 Oct 19 2010

I had "udev.loglevel=info" on the kernel command line, but I don't see anything else in syslog.

If not udev, is it clocksource? Whatever it is, it makes F14 unworkable on a server.
Comment 3 Fedora Update System 2011-06-23 14:25:31 EDT
libmtp-1.0.6-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libmtp-1.0.6-3.fc14
Comment 4 Fedora Update System 2011-06-23 23:21:21 EDT
Package libmtp-1.0.6-3.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libmtp-1.0.6-3.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libmtp-1.0.6-3.fc14
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-07-02 15:26:18 EDT
libmtp-1.0.6-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.