Bug 647516 - [RFE] Automatic discovery of qdev structure/properties
[RFE] Automatic discovery of qdev structure/properties
Status: CLOSED DUPLICATE of bug 557939
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 693512
  Show dependency treegraph
 
Reported: 2010-10-28 12:02 EDT by Glauber Costa
Modified: 2015-05-24 20:06 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-26 04:59:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Glauber Costa 2010-10-28 12:02:17 EDT
Qdev should be able to output which devices are available on the system, and which properties each device have. Our only current option is to parse -help output, which is cumbersome.

-device [dev] ? is a suggestion for command line switch, but the mechanics of it are pretty open.
Comment 1 Markus Armbruster 2011-02-18 01:56:20 EST
There's "-device \?" and "-device DRIVER,\?".  But what we really want here is a solution in QMP.
Comment 2 Markus Armbruster 2011-04-29 05:02:07 EDT
Related bug 647516.
Comment 3 Markus Armbruster 2011-04-29 05:02:55 EDT
Buttefingers... related bug 557939.
Comment 5 Markus Armbruster 2011-06-07 09:22:02 EDT
QMP solution is related to (intertwined with?) upstream QAPI schema work.  Moving to RHEL-7.
Comment 7 Markus Armbruster 2013-09-10 04:25:24 EDT
Some relevant QMP commands have been created since comment#5:

* qom-list-types

* device-list-properties

As far as I can tell, libvirt already uses them.

However, they don't quite cover everything in -device help.  Missing
bits include:

* Bus type: DeviceClass member bus_type

* Alias name: DeviceClass method qdev_class_get_alias()

* Device categories: DeviceClass member categories (new upstream, not
  yet in RHEL-7)

* Description: DeviceClass member desc

* no-user: DeviceClass member no_user

Not sure libvirt really needs all of them.
Comment 11 Amos Kong 2014-05-26 04:59:39 EDT
According to comment #9, close this bug.


qdev structure/properties are defined in qapi-schema.json, the content will be dumped out for management when we finished bz 557939.

*** This bug has been marked as a duplicate of bug 557939 ***

Note You need to log in before you can comment on or make changes to this bug.