Bug 64758 - Install program cannot install from Tru64 NFS server
Install program cannot install from Tru64 NFS server
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 12:12 EDT by Jeremy Sanders
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-09 00:38:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Sanders 2002-05-10 12:12:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
We have a Compaq Tru64 4.0g machine exporting using nfs a directory containing
the RedHat 7.3 install tree.

The install program (on the network boot disk) is unable to mount the nfs
directory even though it exists. This is not due to the install program not
finding the correct files in the tree, but the mount command fails. Also (nul)
is printed on to the background of the install screen.

The install program is able to mount the directory for a RH7.2 and a Sun
machine. Once RH7.3 is installed from cdrom, it is also able to mount the
directory from the Tru64 machine the standard way.

I suspect this is due to the options being used to mount the directory, but this
requires more investigation.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run network install program
2. Choose nfs install
3. Point install program to nfs export on a Tru64 4.0g machine
	

Actual Results:  Install cannot mount specified directory.

Expected Results:  Should have been able to mount directory.

Additional info:

Here is the rpcinfo output for the tru64 machine:

   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    395179    1   tcp   1023
    395177    1   tcp   1021
    395176    1   tcp   1022
    395175    1   tcp   1018
    100005    1   udp   1030  mountd
    100005    3   udp   1030  mountd
    200023    1   udp   1030
    100005    1   tcp    717  mountd
    100005    3   tcp    717  mountd
    100024    1   udp   1032  status
    100024    1   tcp   1025  status
    100021    1   tcp   1026  nlockmgr
    100021    3   tcp   1026  nlockmgr
    100021    4   tcp   1026  nlockmgr
    100021    2   tcp   1026  nlockmgr
    100020    3   tcp   1026  llockmgr
    100021    1   udp   1033  nlockmgr
    100021    3   udp   1033  nlockmgr
    100021    4   udp   1033  nlockmgr
    100021    2   udp   1033  nlockmgr
    100020    3   udp   1033  llockmgr
    100003    2   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   udp   2049  nfs
    100003    3   tcp   2049  nfs
    100004    2   udp    632  ypserv
    100004    2   tcp    633  ypserv
    100004    1   udp    632  ypserv
    100004    1   tcp    633  ypserv
    100007    2   tcp    638  ypbind
    100007    2   udp    640  ypbind
    100007    1   tcp    638  ypbind
    100007    1   udp    640  ypbind
    100009    1   udp   1022  yppasswdd
    100069    1   udp    653  ypxfrd
    100069    1   tcp    655  ypxfrd
    100011    1   udp   1057  rquotad
    100068    2   udp   1058
    100068    3   udp   1058
    100068    4   udp   1058
    100083    1   tcp   1028
Comment 1 Michael Fulbright 2002-05-13 15:17:20 EDT
Matt do you have any ideas?
Comment 2 Jeremy Sanders 2002-05-14 06:40:58 EDT
More data: the installer uses the NFS options
ro,v2,rsize=8192,wsize=8192,hard,udp,nolock when mounting the install tree. A
mount of the Tru64 system from a 7.2 and 7.3 system using these options works,
so it doesn't appear to be the options which are the problem. I suppose the only
other differences are nfs-utils and the kernel on the install disk.
Comment 3 Jeremy Katz 2003-07-09 00:38:24 EDT
I think this should be fixed with our current codebase.  No Tru64 boxes handy to
test against, though.

Note You need to log in before you can comment on or make changes to this bug.