Bug 64762 - Data scrambled printing to SMB printers.
Data scrambled printing to SMB printers.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 13:43 EDT by Jim Shanks
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-02 04:28:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
local.adl from system that scrambles data to SMB printer. (544 bytes, application/octet-stream)
2002-06-18 00:24 EDT, Jim Shanks
no flags Details

  None (edit)
Description Jim Shanks 2002-05-10 13:43:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I've tried two different workstations now that were previously running fine one 
RH 7.2 printing to printers on Windows 2000 and Windows 98 workstations, but 
now the data seems to get scrambled in the spooling process.  The Epson Stylus 
Photo 700 connected to a Windows 98 workstation just spits out pages of junk.  
A Brother HL-1440 connected to a Windows 2000 workstation prints out part of a 
page, then junk.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 7.3 (i386)
2. Add a SMB printer in the Printconf-gui
3. Print a US-Letter Test Page
	

Actual Results:  At least with the Brother HL-1440, a page is printed (actually 
2 pages), but both pages are scrambled.

Expected Results:  Should print test page correctly.  (As in RH 7.2)

Additional info:

I have unistalled SAMBA and installed version samba-2.2.4-2 (downloaded from 
samba.org).  That didn't solve the problem.

WORKAROUND:  I then uninstalled LPRng, printconf and printconf-gui and then 
installed LPRng-3.7.4-28.i386, printconf-0.3.61-3, and printconf-gui-0.3.61-3 
from the RH 7.2 updates.  That solves the SMB print problem although I'm not 
sure what problems it will create.  In any case, the problem is with LPRng3.8.9-
3 included with RH 7.3.
Comment 1 Jim Shanks 2002-05-13 09:15:22 EDT
Right test procedure, wrong conclusion.  It seems that the new version of 
printconf is causing the problem.  I can leave LPRng3.8.9-3 installed and just 
downgrade to printconf and printconf-gui 0.3.61-3 and the problem goes away.  
If I get a minute, I'll try to debug the config files.
Comment 2 Need Real Name 2002-05-18 05:25:26 EDT
I have the same problem with a HP500 printer that is hooked up to a W98 
computer.  RH7.2 printed fine via SMB, but RH7.3 does not.
Comment 3 Need Real Name 2002-05-19 02:22:57 EDT
 I confirm that downgrading to the printconf* files from RH7.2 fix the 
printing problem.  The test pages from printconf-gui work as do the printer 
test files for OpenOffice 1.0.  --Larry
Comment 4 Tim Waugh 2002-06-14 10:44:11 EDT
fwheeler_1@yahoo.com: just to confirm, do you mean that those test pages work 
_after_ downgrading printconf?  They're broken before doing that, yes?
Comment 5 Jim Shanks 2002-06-14 10:58:55 EDT
Yes . . . The printconf distributed with RH 7.3 is broken.  Downgrading to the 
printconf for RH 7.2 fixes the problem.
Comment 6 Jim Shanks 2002-06-14 12:43:47 EDT
Forgot to mention . . . after downgrading the printconf, re-setup the printer.
Comment 7 Need Real Name 2002-06-16 01:59:48 EDT
Yes, you are correct.  Using the version that came with 7.3, test pages 
_wouldn't_ print correctly.  After downgrading to the version that came with 
7.2 test pages printed correctly.  I confirm everything that jshanks@scn.net 
has found as far as problems and solutions.
Comment 8 Tim Waugh 2002-06-17 08:39:31 EDT
I'm having trouble reproducing this.  Which version of printconf are people 
using successfully?  The one that _came_ with 7.2 (0.3.44-1), or the latest 
one issued as an update for 7.2 (0.3.61-4.1)? 
 
Could someone please attach /etc/alchemist/namespace/printconf/local.adl from 
an installation that prints garbage?  Thanks.
Comment 9 Tim Waugh 2002-06-17 09:10:32 EDT
Another thing to try: change 'translate="yes"' to 'translate="no"' in 
/var/spool/lpd/<queuename>/script.cfg (cf. bug #66141).
Comment 10 Jim Shanks 2002-06-17 10:29:27 EDT
I'll attach the file tonight . . . my test machine is at home.  As per my first 
posting, the printconf that I downgraded to is printconf-0.3.61-3.
Comment 11 Jim Shanks 2002-06-18 00:24:55 EDT
Created attachment 61344 [details]
local.adl from system that scrambles data to SMB printer.
Comment 12 Jim Shanks 2002-06-18 00:38:56 EDT
Just tried changing translate='yes' to translate='no' in the
/var/spool/lptd/<queuename>/script.cfg.  That indeed solved the problem.  Seems
that this is the same bug as 66141.  Thanks.
Comment 13 Tim Waugh 2002-06-18 06:45:34 EDT
In that case, it should be that you can change this setting in the 
printconf-gui tool. (The problem was on _adding_ queues, but editing should 
work.)  Can anyone confirm that this works?
Comment 14 Tim Waugh 2002-06-18 07:16:59 EDT
Incidentally, this defaults to 'no translation' in 0.4.2-1.
Comment 15 Need Real Name 2002-07-02 04:28:33 EDT
Yes, It works. I tried add new samba printer with printool-gui and then try edit
configuration (with printtol-gui) and removing translation works good.

Note You need to log in before you can comment on or make changes to this bug.